1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ambilight problem mit externen geräten

Discussion in 'German Talk' started by TheIngsten, 17 June 2018.

  1. TheIngsten

    TheIngsten New Member

    Messages:
    3
    Hardware:
    RPi3
    Also. Die LEDs funktionieren mit kodi ohne Probleme wenn ich beispielsweise youtube laufen lassen. Wenn dann externe Quellen kommen wie beispielsweise Sky oder chromcast sprechen die LEDs nicht auf das Signal an. Der video grabber fushicai chipsatz funktioniert. Konnte ein Bild mittel screenshot für das croppen in hyperion machen. Die ganze kette bis raspberrypi3 scheint in Ordnung zu sein. Die hyperion config kann ich später mal hoch laden falls es für weitere eine fehlerlösung nötig ist.

    1. // Automatically generated configuration file for Hyperion ambilight daemon
    2. // Notice: All values are explained with comments at our wiki: wiki.hyperion-project.org (config area)
    3. // Generated by: HyperCon (The Hyperion deamon configuration file builder)
    4. // Created with HyperCon V1.03.3 (22.10.2017)
    5. {
    6. // DEVICE CONFIGURATION
    7. "device" :
    8. {
    9. "name" : "Testify",
    10. "type" : "ws2801",
    11. "output" : "/dev/spidev0.0",
    12. "rate" : 1000000,
    13. "colorOrder" : "rgb“
    14. },
    15. // COLOR CALIBRATION CONFIG
    16. "color" :
    17. {
    18. "channelAdjustment" :
    19. [
    20. {
    21. "id" : "default",
    22. "leds" : "*",
    23. "pureRed" :
    24. {
    25. "redChannel" : 255,
    26. "greenChannel" : 0,
    27. "blueChannel" : 0
    28. },
    29. "pureGreen" :
    30. {
    31. "redChannel" : 0,
    32. "greenChannel" : 230,
    33. "blueChannel" : 0
    34. },
    35. "pureBlue" :
    36. {
    37. "redChannel" : 0,
    38. "greenChannel" : 0,
    39. "blueChannel" : 200
    40. }
    41. }
    42. ],
    43. "temperature" :
    44. [
    45. {
    46. "id" : "default",
    47. "leds" : "*",
    48. "correctionValues" :
    49. {
    50. "red" : 255,
    51. "green" : 255,
    52. "blue" : 255
    53. }
    54. }
    55. ],
    56. "transform" :
    57. [
    58. {
    59. "id" : "default",
    60. "leds" : "*",
    61. "hsl" :
    62. {
    63. "saturationGain" : 1.0000,
    64. "luminanceGain" : 1.0000,
    65. "luminanceMinimum" : 0.0000
    66. },
    67. "red" :
    68. {
    69. "threshold" : 0.0000,
    70. "gamma" : 2.5000
    71. },
    72. "green" :
    73. {
    74. "threshold" : 0.0000,
    75. "gamma" : 2.5000
    76. },
    77. "blue" :
    78. {
    79. "threshold" : 0.0000,
    80. "gamma" : 2.5000
    81. }
    82. }
    83. ],
    84. // SMOOTHING CONFIG
    85. "smoothing" :
    86. {
    87. "type" : "linear",
    88. "time_ms" : 200,
    89. "updateFrequency" : 20.0000,
    90. "updateDelay" : 0
    91. }
    92. },
    93. // V4L2 GRABBER CONFIG
    94. "grabber-v4l2" :
    95. {
    96. "device" : "/dev/video0",
    97. "input" : 0,
    98. "standard" : "PAL",
    99. "width" : -1,
    100. "height" : -1,
    101. "frameDecimation" : 2,
    102. "sizeDecimation" : 8,
    103. "priority" : 900,
    104. "mode" : "2D",
    105. "cropLeft" : 0,
    106. "cropRight" : 0,
    107. "cropTop" : 0,
    108. "cropBottom" : 0,
    109. "redSignalThreshold" : 0.0,
    110. "greenSignalThreshold" : 0.0,
    111. "blueSignalThreshold" : 0.0
    112. },
    113. // FRAME GRABBER CONFIG
    114. "framegrabber" :
    115. {
    116. "width" : 64,
    117. "height" : 64,
    118. "frequency_Hz" : 10.0,
    119. "priority" : 890
    120. },
    121. // BLACKBORDER CONFIG
    122. "blackborderdetector" :
    123. {
    124. "enable" : true,
    125. "threshold" : 0.5,
    126. "unknownFrameCnt" : 600,
    127. "borderFrameCnt" : 50,
    128. "maxInconsistentCnt" : 10,
    129. "blurRemoveCnt" : 1,
    130. "mode" : "default"
    131. },
    132. // KODI CHECK CONFIG
    133. "xbmcVideoChecker" :
    134. {
    135. "xbmcAddress" : "127.0.0.1",
    136. "xbmcTcpPort" : 9090,
    137. "grabVideo" : true,
    138. "grabPictures" : true,
    139. "grabAudio" : true,
    140. "grabMenu" : true,
    141. "grabPause" : true,
    142. "grabScreensaver" : true,
    143. "enable3DDetection" : true
    144. },
    145. // BOOTEFFECT CONFIG
    146. "bootsequence" :
    147. {
    148. "color" : [0,0,0],
    149. "effect" : "Running dots",
    150. "duration_ms" : 6000,
    151. "priority" : 700
    152. },
    153. // JSON SERVER CONFIG
    154. "jsonServer" :
    155. {
    156. "port" : 19444
    157. },
    158. // PROTO SERVER CONFIG
    159. "protoServer" :
    160. {
    161. "port" : 19445
    162. },
    163. // BOBLIGHT SERVER CONFIG
    164. "boblightServer" :
    165. {
    166. "port" : 19333,
    167. "priority" : 900
    168. },
    169. // EFFECT PATH
    170. "effects" :
    171. {
    172. "paths" :
    173. [
    174. "/storage/hyperion/effects",
    175. "/usr/share/hyperion/effects"
    176. ]
    177. },

    OpenELEC (official) Version: 8.0.4

    OpenELEC:~ # LD_LIBRARY_PATH=/storage/hyperion/bin /storage/hyperion/bin/hyperio

    n-v4l2 --screenshot

    hyperion-v4l2:

    version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225

    build time: Apr 5 2018 01:57:25

    V4L2GRABBER INFO: width=720 height=576

    V4L2GRABBER INFO: pixel format=YUYV

    V4L2GRABBER INFO: signal threshold set to: {0,0,0}

    V4L2GRABBER INFO: started

    V4L2GRABBER INFO: stopped

    Gruß
     
  2. TheIngsten

    TheIngsten New Member

    Messages:
    3
    Hardware:
    RPi3
    Problem gelöst . Framegrabber aus der config gelöscht und es klappt