1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OpenELEC Help with possible grounding issue causing reboots?

Discussion in 'Hardware Support' started by mrl72, 22 June 2018.

  1. mrl72

    mrl72 New Member

    Messages:
    5
    Hardware:
    RPi3
    Hi all

    I got everything up and running on my Rpi3 running OpenElec. I tested everything prior to cutting the LED strips and placing on my TV. Everything worked fine.

    I cut a 5M strip of APA102 into 4 sections. 42 LEDs top/bottom and 24 on each side. I am driving them with a 5V 12A PSU.

    Whatever I tried I could not get the lights to come back on, even with the same Hyperion config. I also noticed that the Rpi3 would start rebooting randomly, or screen would flicker.

    So here's something weird. I had a small section of strip left over that had 10 LEDs left on it. I connected that between the PSU/Rpi3 and the first LED on the first strip on the TV, and it works! All LEDs light up and I have no more reboot issues.

    Wiring looks sound and I've checked it 100 times both at LED end and the connectors on the Rpi3.

    Any idea what could be causing this?
     
  2. Akriss

    Akriss Active Member

    Messages:
    299
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    When testing with the 10 LED strip, are you using a short wires from the Pi to the LED's, correct?

    And the wire on the production setup are probably much longer, correct?

    If both are a yes what is most likely happening is the signal is to weak from the RPi's 3.3v GPIOS. On long runs of wire you well add a bit of resistance, the longer the wire is.

    The APA102 led's are spec'd to receive a 5v signal (-/+5%).

    You can use a level shifter/buffer to bump the 3.3v signal to 5v.

    Search the forums for "Level shifter" or "74AHCT125" the model # of a recommended level shifter. lot's of good info on the forums =)

    Hope its of help.
     
  3. mrl72

    mrl72 New Member

    Messages:
    5
    Hardware:
    RPi3
    Hi

    I'm using a 5v 12amp PSU to power the LED strip, with just the 3 wires coming from the Pi3 (ground, clock and the DI/DO) that are about 6" long. The PSU sits next to the Pi3 on the back of the TV, so the wires are very short.

    I ended up replacing the wires from the PSU and this solved the reboot issue, so I'm thinking it could be a bad wire/solder issue. Things were actually working for the past 2 days and then all of a sudden things stopped working again. This is now what I'm getting and I'm totally baffled!

    Only the bottom row strip (0-42) are illuminated and the first 6 LEDs on the side strip (43-49) are lit up. If I choose a color manually in HyperCon (on SSH tab) then the opposite color to what I choose lights up. Red is blue, blue is red etc. My config settings have not changed at all.

    If I power down everything then power on the LEDs first, then the Pi3, I then get the "rainbow" effect on the bottom strip only as it boots to Kodi. And then it seems random LEDs remain on, say 4-5-6 will be different colors, 10-11-12 will be different colors etc. even though I have in the config not turned on for the Kodi menu. Very strange!

    I've tried everything I can think of to get it to work. I've uninstalled Hyperion. I've created a config file from scratch. I've checked all the connections again. Even that 10-LED short strip when connected to the Pi3 by itself is acting strange now. Red is blue, blue is red even on that whereas before it was working fine.

    Any ideas what could be causing this? Could it be a bad Pi3? I've spent so much time and money on this now I'm ready to just throw it all in the trash to be honest!

    Note, the only "power" related issue I have on the Pi3 is I get the lightning bolt top right corner of screen, even when using a 5V 2amp power source. I've ordered a new 3Amp power supply to hopefully resolve this issue. I just don't know if that is related or not.

    Cheers.
     
    Last edited: 25 June 2018