1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LEDs durch Weiß-Kalibrierung sehr dunkel geworden

Discussion in 'German Talk' started by Hoax, 26 September 2018.

  1. Hoax

    Hoax New Member

    Messages:
    1
    Hardware:
    RPi3
    Hallo zusammen,

    ich habe bereits mehrere Fernseher mit Ambilights ausgestattet, aber mein eigener und aktueller Fernseher ist etwas zickig [​IMG] Die LEDs sind eigentlich immer von zwei verschiedenen Herstellern direkt in China gekommen. Bspw. Hello Fish. Bisher war immer alles super, ob bei mir oder bei meinen Freunden.

    Allerdings habe ich mir kürzlich einen neuen Fernseher gekauft und nach der Kalibrierung der LEDs (auch von Hello Fish), sind diese nur noch sehr dunkel gewesen. Der Hauptgrund ist wohl, dass die Weißwert-Anpassung sehr viel Helligkeit genommen hat. Ursprünglich wurde weiß als sehr helles pink ausgegeben. Durch Anpassen der Werte für Blau und Rot (teils drastische Reduktion) konnte ich perfektes weiß erzielen, ABER jetzt leuchten die LEDs nur noch relativ dunkel. Alle anderen Fernseher waren eigentlich noch immer schön hell.

    Hinzu kommt, dass ich jetzt das Setup aus ext. Grabber usw benutze, damit auch 4K korrekt funktioniert, da mein altes Setup nur aus einem Raspberry Pi bestand. Der ext. Grabber ist ja durch sein analoges Signal sowieso dunkler als bei einem digitalen Signal (wieso ist das eigentlich so?)

    Ich habe jedenfalls auch über HyperCon Testbilder generiert und der Unterschied mit Grabber und ohne (also nur Pi) sind schon deutlich sichtbar. Der Grabber macht das Bild deutlich dunkler, weswegen die LEDs sich a) auch nicht immer so gut angesprochen fühlen und b) generell dunklere Farben abgeben, was den o.g. Effekt verstärkt.

    Frage nun: Kann ich dem irgendwie entgegenwirken und die LEDs heller kriegen, ohne das Weißlevel zu beeinträchtigen?

    Übrigens: Es handelt sich um einen 75 Zoll Fernseher, ich brauche genau die 5m Länge der LED Rollen, um einmal rum zu kommen (es fehlt sogar unten in der Mitte ein Stück von 5 LEDs). Ich nutze dafür ein 5V 10A Netzteil. Meiner Rechnung nach sollte das aber passen? (Der Raspberry Pi wird extra mit Strom versorgt). Soweit ich mich erinnere brauchen die LEDs 9,64W pro Meter, würde also mit 48W knapp aufgehen. WENN das Netzteil wirklich auch 50W ohne Ausnahme schafft [​IMG]

    Frage 2: Kann es helfen, wenn ich ein zweites Netzteil dazu lege, damit die 48W Strombedarf auch garantiert werden? Sind die LEDs vlt. so dunkel weil die maximal geforderte Strommenge nicht ankommt?

    Frage 3: Ist es problemlos möglich irgend ein weiteres 5W Netzteil anzuschließen (bspw. ein altes vom Handy?), damit die Kapazität ausreicht? Sollte man dabei etwas beachten, oder kann ich die beiden Pins für 5V und GND einfach auf die anderen löten (evtl. sogar besser am Ende?). Das jetzige 50W Netzteil ist übrigens sowohl vorne als auch hinten an den LED-Strang angelötet, liefert also von beiden Seiten Saft.

    Vielen Dank schonmal für eure Unterstützung!

    Config:

    Code:
    {
       // DEVICE CONFIGURATION
       "device" :
       {
          "name"       : "Ambi-Grabber",
          "type"       : "ws2801",
          "output"     : "/dev/spidev0.0",
          "rate"     : 1000000,
          "colorOrder" : "rbg"
       },
    
       // COLOR CALIBRATION CONFIG
       "color" :
       {
          "channelAdjustment" :
          [
             {
                "id"   : "default",
                "leds" : "*",
                "pureRed" :
                {
                   "redChannel"      : 65,
                   "greenChannel"      : 0,
                   "blueChannel"      : 0
                },
                "pureGreen" :
                {
                   "redChannel"      : 0,
                   "greenChannel"      : 255,
                   "blueChannel"      : 0
                },
                "pureBlue" :
                {
                   "redChannel"      : 0,
                   "greenChannel"      : 0,
                   "blueChannel"      : 50
                }
             }
          ],
          "temperature" :
          [
             {
                "id"   : "default",
                "leds" : "*",
                "correctionValues" :
                {
                   "red"    : 255,
                   "green"   : 255,
                   "blue"    : 255
                }
             }
          ],
          "transform" :
          [
             {
                "id"   : "default",
                "leds" : "*",
                "hsl" :
                {
                   "saturationGain"   : 1.0000,
                   "luminanceGain"      : 1.2000,
                   "luminanceMinimum"      : 0.0000
                },
                "red" :
                {
                   "threshold"    : 0.0100,
                   "gamma"        : 2.5000
                },
                "green" :
                {
                   "threshold"    : 0.0100,
                   "gamma"        : 2.5000
                },
                "blue" :
                {
                   "threshold"    : 0.0100,
                   "gamma"        : 2.5000
                }
             }
          ],
       // SMOOTHING CONFIG
          "smoothing" :
          {
             "type"            : "linear",
             "time_ms"         : 100,
             "updateFrequency" : 25.0000,
             "updateDelay"     : 0
          }
       },
    
       // V4L2 GRABBER CONFIG
       "grabber-v4l2" :
       {
          "device" : "/dev/video0",
          "input" : 0,
          "standard" : "PAL",
          "width" : 720,
          "height" : 405,
          "frameDecimation" : 2,
          "sizeDecimation" : 8,
          "priority" : 900,
          "mode" : "2D",
          "cropLeft" : 15,
          "cropRight" : 15,
          "cropTop" : 0,
          "cropBottom" : 0,
          "redSignalThreshold" : 0.1,
          "greenSignalThreshold" : 0.1,
          "blueSignalThreshold" : 0.1
       },
    
       // BLACKBORDER CONFIG
       "blackborderdetector" :
       {
          "enable" : true,
          "threshold" : 0.05,
          "unknownFrameCnt" : 600,
          "borderFrameCnt" : 50,
          "maxInconsistentCnt" : 10,
          "blurRemoveCnt" : 1,
          "mode" : "default"
       },
    
       // BOOTEFFECT CONFIG
       "bootsequence" :
       {
          "color" : [0,0,0],
          "effect" : "Cinema brighten lights",
          "duration_ms" : 3000,
          "priority" : 700
       },
    
       // JSON SERVER CONFIG
       "jsonServer" :
       {
          "port" : 19444
       },
    
       // PROTO SERVER CONFIG
       "protoServer" :
       {
          "port" : 19445
       },
    
       // EFFECT PATH
       "effects" :
       {
          "paths" :
          [
             "/storage/hyperion/effects",
             "/usr/share/hyperion/effects"
          ]
       },
    
       // NO FRAME GRABBER CONFIG
       // NO KODI CHECK CONFIG
       // NO BOBLIGHT SERVER CONFIG
       // NO JSON/PROTO FORWARD CONFIG