1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + Other Software RPI3b+ hangs when leds are connected

Discussion in 'Hardware Support' started by Zyarra, 22 April 2019.

  1. Zyarra

    Zyarra New Member

    Messages:
    6
    Hardware:
    RPi3
    Hi,
    my problem is that my rpi freezes at least 5/10 times, shh and everything stops, leds hyperion and video grabber still work.
    using raspbian
    the other 3-5 times it works flawlessly.

    When it hangs, RPI still gives a picture on HDMI(only if i connected it before starting though) but completely unresponsive, i can type anything but it doesnt react, cannot restart etc.
    but with a hard reset it works again(ctrl alt del 6 times cannot do the restart, its trying but it gets stuck).

    when i dont connect leds it works 100/100 times without hanging

    this is my second rpi because i accidentally burned out the others gpio

    any clue why this happens?

    PSU for both leds and rpi is sufficient.
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,257
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    maybe a bad sd card?
     
  3. Zyarra

    Zyarra New Member

    Messages:
    6
    Hardware:
    RPi3
    Ah... the only thing i didnt replace yet. How obvious. Thanks a lot for thr input. I will try in the following days.
     
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,257
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    rpis have often problems with the sd card... just give it a try :)
     
    • Like Like x 1