Pi Zero W + adalight not working?

  • Hi guys!


    I've been using an Arduino uno + the first Adalight kit for a while now (yeah the old one with big led lights ;) ), it's working really well with my windows pc.
    I decided to make a DIY HDMI ambilight clone with it, so I got the usual HDMI splitter, HDMI2AV and the UTV007 capture card, along with the Rasberry pi Zero W.


    I installed Raspbian Lite, configured the wifi and all, then installed Hyperion with Hypercon, plugged everything, configured it, then rebooted it.
    But since then, I haven't been able to make the led work.
    The adruino and UTV007 are recognized perfectly in Raspbian when I search them in the /dev/ list and plug/unplug them, and are configured correctly in Hypercon.


    The lights are doing the usual starting color flashes when I restart Hyperion, but then they all stay off.
    I tried to manually change the light colors with the colorpicker and the android app, I have no error, but here too nothing works.
    I can see the RX led flashing on the Arduino Uno showing that it's obviously receiving some information.
    Also, when I try to take a grabber screenshot, hypercon crashes, until I manually reboot my raspberry.


    I searched a solution in this forum and others, and try so many things, but I just can't make it work...


    I you had an idea of why it's not working, and could help me with that, that would be really great :D


    Here is my hyperion json config file:
    [MEDIA=pastebin]K367YqwA[/MEDIA]
    and here is my hyperion log file:
    [MEDIA=pastebin]Su94VLNb[/MEDIA]


    thanks ;)


    Edit:
    I finally got it working by changing the rate to 115200, and the delay by 3000 (got them in someone else json file), and now I can finally light it up with the colorpicker.
    But sadly the capture device still isn't working.


    Edit2:
    I also tested the grabber on my PC with the UTV driver, and it works well too, but not with the pi0.
    I took it apart to check it, and it's a true UTV007.


    Edit3:
    I finally found the problem! The powered usb hub I was using didn't give me enough power, but another one with more power worked perfectly!
    I will leave this message here just in case other people might have the same issue :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!