RPi 1 Model b , WS2812b . Cant get anything

  • I have a RPi 1 Model b paired with some WS2812b pwm LEDS. I can't for the life of me figure out where I'm getting my issues. I have tried OSMC, Raspbian, Openelec, and Kodi builds. I managed to have like 5 leds of my 5m 60led/m ws2812b light up for like 5 min, but other than that nothing. I keep getting and odd issue acroos the different OS's. When installation of Hyperion from Hypercon Is finished it fails to auto reboot the OS. No lights are on. I am forced then to manually reboot from either terminal or removing the micro usb it. Either method gives me no leds on start, however, after the boot sequence starts I eventually cant boot into the os. It freezes. Raspbian everything goes smoothly, even shows Hyperion starting (again still no lights) until something along the lines of "printk messages dropped" comes up and the OS freezes. OSMC i have the Hyperion log attached, however, it reacted the same way as Raspbian accept i got an error:


    "Kernel panic - not syncing: Fatal expectation in interruption"
    ---{ end kernel panic - not syncing: Fatal expectation in interruption
    random:crng init done

    If I reboot, Hyperion is no longer installed and there is no config file, so I have to start the entire process again.

    Update: With this build of OSMC it looks like it's completely corrupt. It gives the same error on every boot, and goes no further.


  • Update: installed fresh OS on formatted SD and things aren't freezing anymore. Hyperion just refuses to start. I tested python script to insure hardware is working, and I can run all 300 LEDs off it. If it makes a difference I'm using a level converter in the mix, however I have tried without it. Seems maybe software related.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!