Hyperion NG no colors over USB grabber

  • Hi all,
    I am using Hyperion NG V2 Alpha 2 on my Raspberry 1B. I have now successfully configured everything. Sadly I have no colors over the USB grabber, only white. But when I start effects or only some colors it works with the exact color.
    Here is a picture what Hyperion is getting over the USB grabber:

    I was running the same setup with the old hyperion and it worked with colors before.

    Part of my Hyperion NG config (full one is attached):

    Part of my old hyperion config (full one is attached):

  • Hi,

    what hardware and input material are you using?

    What result is proived by the following commands?

    $ v4l2-ctl -d /dev/video0 --list-formats-ext


    $ v4l2-ctl --list-ctrls


  • By the way, I have now upgraded my raspi 1B with a 3B with a fresh new installation and the result is the same.

    @GnaGetier here is the output:

    @Noret PAL settings are definitly correct :( I am already using the old hyperion and there it works great with colors. On hyperion NG i tried to apply my settings similar.

  • So no saturation settings problem.

    Did you migrate from hyperion to NG on the same pi installation? I'm not an expert but to my understanding the live video should not be affected by hyperion if the image and pixel format is correct. So hyperion.ng should receive the same image feed on the same installation.

    Am I right, anyone?

    Unfortunately I don't know anything else you could look for.


  • Hello, I have exactly the same problem.

    Here is my output


  • 'lsusb' output please!

    Sorry for the late reply, here is my output:

    Bus 001 Device 004: ID 1b71:3002 Fushicai USBTV007 Video Grabber [EasyCAP]
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Thanks for the information, seems to fixed my issue also.
    The only issue that is left for me, is that after setting up Hyperion as a service in debian I get an error in my browser after starting the raspberry pi: 404 - Requested file: index.html

    After restarting then the service over the terminal it works fine.

  • I have the same problem, but I don't understand why I should switch my converter and grabber from PAL to NTSC.
    My signal is PAL and mostly 1080P50.
    With an early beta (GitHub-9b860aa/2905842-1507995442) of hyperion ng the configuration works with PAL.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!