WLED Talk & Support

  • Einen schönen Abend,


    ich habe da mal eine Frage bzgl. WLED. Im englischen Wiki wird in die Dataleitung ein 62Ohm Widerstand eingelötet und im deutschen Wiki ist an selbiger Stelle ein 470Ohm Widerstand, welchen muss ich denn nun nehmen? Und weiter bin ich mir nicht ganz sicher wieviel Watt der Wiederstand haben sollte, die gängigsten zum basteln scheinen ja 0,25W und 0,6W zu sein.


    Vielen Dank schon einmal.


    Der Widerstand ist eher Schutzmaßnahme und hat keine direkte funktionale Bedeutung, daher ist der sinnvoller Bereich recht groß.
    Wenn man LevelShifter hat, ist das recht egal, kannst im Prinzip irgendwas zwischen 60 und 600 Ohm nehmen (wobei ich eher ab 100 empfehlen würde). 0,25W ist dann ausreichend.
    Ohne LevelShifter (ist aber eher Frickellösung auf gut Glück, da out-of-spec) macht Sinn eher kleinere Werte einzusetzen (mit 62 Ohm kann man sicherlich anfangen), sonnst ist der Hi-Pegel ggf. nicht gut genug. Trägt dann aber nicht so gut zum Schutz bei.

  • Stimmen die Farben wenn du etwas in WLED Webui einstellst?

    Wenn ja, kann das eigentlich nur an deinen Einstellungen (Farbabgleich usw.) liegen.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Guten Tag,


    ich habe nun auch endlich auf die sk6812 gewechselt. Läuft über WLED auch. Jetzt ist mir aber aufgefallen, dass vor allem in dunklen Szenen das Bild eher weiß statt schwarz/LED aus ist. Gibt es da eine Einstellung? Den Grabber habe ich nicht verändert.

    Ohne mich jetzt komplett durch alles zu lesen hatte ich das gleiche Problem mit meinem Grabber.


    Lösung in meinem Fall:

    Die default Werte im Grabber sind für Brightness / Contrast / Saturation 128.

    Ich habe das Brightness auf 100 gesetzt.

    Dann sind die LEDs auch in dunklen Szenen aus und nicht mehr weiß.


    Hier noch der Befehl :


    v4l2-ctl --set-ctrl brightness=100


    Du kannst ja mit


    v4l2-ctl --all


    auslesen was die Werte des Grabbers im Moment sind.

    Oder auch welche Auflösungen er unterstützt mit


    v4l2-ctl --list-formats-ext

  • Ja klar die Werte werden im Grabber gespeichert.

    Mir schien es so als würde er mit default Brightness ein wenig übersteuern. Mit dem Wert 100 / Grabber und einem Wert von 90 / WebGui habe ich eine natürliche Helligkeit und kräftige aber nicht übertriebene Farben.

  • Hallo zusammen,
    ich bin gerade dabei auch auf den Hyperion+WLED-Zug aufzuspringen (unter Verwendung eines NodeMCU v3) und habe das Problem, dass alle Befehle, die von Hyperion kommen erst nach ca. 5 Sekunden umgesetzt werden.

    Das gilt sowohl für TV-Inhalte (via Android Grabber gegrabbt) als auch für das Starten von Effekten über das Hyperion-Webinterface. Die Effekte an sich laufen aber alle sehr flüssig.


    Des Weiteren ist mir aufgefallen, dass während der Hyperion-Server läuft das WLED-Webinterface sich praktisch nicht nutzen lässt. (Sehr langsam bzw. nicht erreichbar)


    Habt ihr da eine Idee?

  • Servus,

    selbiges Problem habe ich auch, alle Effekte kommen erst nach ca 4 Sekunden.

    NodeMCU - Raspi 3b

    Es ist alles komplett neu aufgesetzt und es läuft nichts sonst drauf.

    ein Ping sagt:


    raspi

    PING 192.168.1.56   56(84) bytes of data.

    64 bytes from elara.rd.net (192.168.1.56): icmp_seq=1 ttl=64 time=1.06 ms

    64 bytes from elara.rd.net (192.168.1.56): icmp_seq=2 ttl=64 time=1.15 ms

    64 bytes from elara.rd.net (192.168.1.56): icmp_seq=3 ttl=64 time=1.18 ms

    64 bytes from elara.rd.net (192.168.1.56): icmp_seq=4 ttl=64 time=1.18 ms

    wled

    PING 192.168.1.208 (192.168.1.208) 56(84) bytes of data.

    64 bytes from 192.168.1.208: icmp_seq=1 ttl=128 time=29.5 ms

    64 bytes from 192.168.1.208: icmp_seq=2 ttl=128 time=43.9 ms

    64 bytes from 192.168.1.208: icmp_seq=3 ttl=128 time=16.8 ms

    64 bytes from 192.168.1.208: icmp_seq=4 ttl=128 time=31.1 ms

  • welchen pi nutzt du und läuft da noch was anderes drauf?

    Läuft bei mir in einer Unraid VM (ubuntu mini) als einziger nachinstallierter service neben openssh. (wird langfristig in einen Docker Container verfrachtet, es steht aber aktuell ein dedizierter CPU core und 1 GB Speicher zur Verfügung)

    Laut top ist die Auslastung nicht der Rede wert

  • Nachdem ich vom NodeMCU zum ESP32 DevKit v1 gewechselt bin, ist die Verzögerung verschwunden.

    Das ganze läuft jetzt zwar flüssig, jedoch spinnen nun die letzten LEDs (blitzen auf) und die aller letzte LED ist entweder komplett schwarz oder weiß. Vermutlich liegt es am fehlenden Levelshifter...

  • Da scheint alles in Ordnung zu sein, ich kann drücken wie ich will, da tut sich nichts. Beim NodeMCU v3 scheint es das Problem nicht zu geben.


    Was mir noch aufgefallen ist: Mitten im Film blitzt die in WLED eingestellte Farbe immer wieder kurz auf bevor dann wieder die Hyperionbefehle übernommen werden. Kann es sein, dass der Controller crasht/rebootet? Ich kann mir eigentlich nicht vorstellen, dass die Spannung so stark einbricht o. Ä.

  • WLED 0.12.0 "Hikari"!


    Quote from Aircoookie
    • Support for multiple LED outputs (10 on ESP32, 3 on ESP8266). Add even more lights to your installation
    • Pins and LED type can be configured at runtime. No more custom binaries for pin changes
    • Palette previews: You now know what a palette looks like before even applying it
    • Searchable palette and effect lists, making finding your favorites easier
    • Instance list: Simply jump from one WLED device to another without remembering IPs
    • Added four new effects, Aurora, Dynamic Smooth, Tetrix and TV simulator
    • Caching for snappier interface loading
    • Added indicator for Frames per second
    • Various fixes and improvement

    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • Hallo zusammen,


    An die Leute die SK6812-RGBNW Streifen verwenden, was habt ihr unter Auto-calculate white channel from RGB in den WLED Einstellungen gewählt ? Bin mit weder mit Dual (hell aber Farben wirken etwas blass) noch Accurate (manchmal nicht hell genug) ganz zufrieden .


    Danke im Voraus !

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!