Install Hyperion.ng on LibreELEC x86_64/RPi (inoffiziell/unofficially)

  • [QUOTE = "davieboy, post: 33156, member: 10157"] change kodi GUI to 720p for the Pi4, that's really the only thing you need to do after the install to prevent the black screens. Take it you can get to the configuration page ok and everything else is setup in there - GPIO pin etc etc?
    [/ QUOTE]


    After setting the GUI to be limited to 720p, I can see the OSD fine, no blanking.
    However, Hyperion is started (latest Alpha 9 release) but nothing on LEDs.


    I am using GPIO18 for data and GND to GND on WS2812b, but nothing is coming out.
    You say: configuration page...which is the config page? How do I get to it?

  • should be on the pi ip port 8090 then set your GPIO and LED settings in Configuration->LED Hardware :thumbsup:


    LED Controller is where you tell it to use GPIO pin and the LED layout to set your LEDS, remember to check the input position (starting position), should be good to go after that.


    Good Luck

  • Sweet glad you got it up and running :thumbsup:
    yeah 100% agree with you, but I am slowly starting to find out that by doing so it causes other implications for other devices but yeah if all you want is a media player and Hyperion setup GPIO all the way, I have a spare UNO here just in case push comes to shove but its way more hassle than 1 pin on the GPIO :roflmao:


    Look forward to reading your showcase when you get up and running :bigsmile:

  • @Paulchen-Panther
    Hallo Paulchen,
    Dein Script funktioniert nur mit Libre Elec:
    if [ $OS_LIBREELEC -ne 1 ]; then
    echo '---> Critical Error: We are not on LibreELEC -> abort'

    exit 1

    fi

    Kann man ihn prinzipiell auch bei Raspberry OS anwenden, wenn man die Abfrage entsprechend modifiziert? Oder gibt es eine alternative Anleitung zur Installation unter Raspberry OS?

  • @Igor Bujaroski
    Hi Igor,
    especially because you tell us that you have children, you should not leave your 230V supply like shown in your photo. This is no good solution - and not allowed - for use in living rooms.
    You better use a power supply recommended by brindosch here or put it into a safe case with a power connector.

  • Just tried installing this following the instructions in the first post, on a clean libreelec install, but there is nothing on port 8090 so I cant see the hyperion configuration page.


    Raspberry Pi 3 by the way.


    Solved, I messed up by adding Hyperion addon, thinking it was an integration rather than a service, removed it and now the web ui works fine.

  • Lucky007 Hyperion itself already makes use of Python 3 8and this is independent from LibreElec (as hyperion brings everything in its installation it needs).
    If you are talking about the Hyperion Kodi-Add-on, then you should have look at the latest PRs in the specific GitHub repository, where a version with python3 LibreElec support is stored (see https://github.com/hyperion-project/hyperion.control)

  • Hey guys,


    I've just spent hours getting hyperion.ng (2.0.0-alpha.9) to work - unsuccessfully. I've tried following what tutorials and guides I found but I'm stuck and need help and was hoping you guys would be able to render it. I've used the installation script from the first post.


    I run a Raspi 4 and LibreELEC 9.95.1 with what I believe is a APA102 (came with the Lightberry HD). I've since retired all hardware that came with the Lightberry and have connected the LEDs directly to the Raspi. I can also manually drive the LEDs using the Remote Control functionality so I know I connected everything correctly (solid light and effects work, meaning the LEDs actually light up correctly).


    But I can't seem to get the Platform Capture to work. I've tried all shown Types (DispmanX, Framebuffer and QT) and nothing happens, i.e. the LEDs stay dark when playing a video. I've also tried the LED Visualization functionality but that doesn't show the movie I'm actually playing either, it just displays "Hyperion".


    Any idea what I'm doing wrong?


    Thanks in advance for your help and kind regards.

  • Install a stable LibreElec release and not the beta version.

    Suggest you look at the following post for the background

  • Moinsen, aktuell funktioniert Hyperion / Hyperion NG leider noch nicht direkt bzw sauber auf Libreelec 9.95.1...

    Habe die letzen tage extrem viel getestet und schlussendlich auch mit 9.95.1 nur mit einem externen Grabber (rpi3b mit HyperBian) / HDMI/Splitter / HDMI zu AV Convertter zum lafen gebracht. Alles über ein Main-System ( z.b.: rpi4 egal ob local installed Hyperion alt/neu oder Hyperion NG) läuft nicht zu 100 %.


    Bsp.1) da 9.95.1 noch eine "beta" Version ist, bekomme ich dort über ein Hautpsystem ohne zusatzgeräte, nur Hyeperion NG komplett zu laufen, aber die CEC & komplette Soundausgabe ist tod...

    Bsp.2) 9.951 mit den og. Zusatzgerätet, auch 4k Ambilight nutzbar, aber über den dortigen im Libreelec des hauptsystems hinterlegten Audio-Asugabe wird nur 4 Boxen einer 7.1. Anlage trotz statischer 7.1 Konfig angesprochen auch bei 5.1Medium.


    Aktuell läuft alles bei mir super auf einem 75" Samsung TV mit Libreelec 9.2.6, den o.g. & angeschlossenen zusatzgeräten - sprich angefangen mit HyperBian 2K/4K sowie die komplette Soundausgabe von 7.1.


    Ich werde nun abwarten bis eine neue Stabile Version von Libreelec und mich mit diesem es nochmals anzugehen, weil hier bei der aktuelle 9.95.1 die Tonausgabe/Soundausgabe (auch wenn nur ein Teil meiner Anlage damit versorgt wird - sich um welten besser Anhört)..


    VG

  • Install a stable LibreElec release and not the beta version.

    Suggest you look at the following post for the background

    Thank you very much for your prompt answer! I've downgraded to Leia again and everything works. So happy and sorry to bother you with my questions - I used the autoupdate and hence missed the beta update notice. Thanks again!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!