[gelöst] Benötige leider Starthilfe für mein neues Ambilight

  • Hallo Zusammen,


    Ich bin komplett neu hier und habe mich gestern ein wenig umgesehen Glücklicherweise gibt es noch verrücktere als mich. Absolut genial, was sich der eine oder die andere gebaut hat!


    Ich selbst habe vor längerer Zeit mit Boblight begonnen und als totaler Linux Noob war das für mich eine riesen Herausforderung! Nach Wochen des probierens und zusammenstückeln verschiedener Guides, gelang mir schließlich die Installation mit Adalight und einem RPi unter Mac OS. Totaler Quatsch aus heutiger Sicht. Das wäre damals schon einfacher gegangen... Dann kam der Wechsel zu Windows und schließlich der zu LibreELEC. Mit LibreELEC schaute ich mir dann auch Hyperion an und es ist einfach der WAHNSINN. Die Installation und Konfiguration ist einfach genial.


    Leider stoße ich bei der Aufrüstung der LEDs nun auf Probleme.
    Bisher läuft Hyperion auf x86 Basis i.V.m. Adalight auf einem Arduino UNO
    Ich hielt mich bei Adalight an diesen Guide und kaufte auch deren LEDs (2x25):
    https://learn.adafruit.com/ada…ient-tv-lighting/wiring-1


    Beim Umstieg auf LE und Hyperion gelang mir die Konfiguration und Kalibrierung ohne Probleme und es läuft seit ca. 4 Monaten wirklich super.


    Die neuen LEDs sind diese WS2810 streifen:
    https://www.aliexpress.com/sna…146&productId=32259735265


    Ich ging eigentlich davon aus, dass ich die LEDs einfach 1:1 austauschen könne und die Verkabelung gleich bliebe. Leider tut sich bei den neuen Streifen aber nichts, bis auf einzelnes blinken vereinzelter LEDs. Auch das Startsignal des Arduinos - das R->G->B Leuchten - beim booten wird nicht gezeigt. Es scheint also keine Signalübertragung stattzufinden. Mit den alten LEDs funktioniert es nach wie vor. Ich wollte die neuen LEDs lediglich testen, bevor ich mit dem Umbau beginne.


    Ach so - ein stärkeres Netzteil habe ich natürlich für die Streifen besorgt:
    https://www.amazon.de/gp/produ…tle_o08_s00?ie=UTF8&psc=1


    Daran sollte es eigentlich nicht liegen.
    Hätte ich ggf. doch die WS2812 nehmen sollen und mit einem Anderen Sketch arbeiten?


    Hat jemand eine Idee?


    Danke und Grüße

  • Dein Sketch muss immer mit den angeschlossenen LEDs passen, und dort muss auch die Anzahl der LEDs angepasst werden


    aber deine alten leds müssten auch ws2801 sein, richtig?


    zumal hier leider zu wenig infos bzgl hyperion ist...was ist den alles eingestellt? die config wäre hier nützlich

  • Hi @TPmodding


    vielen Dank für Deine Antwort und bitte entschuldige, dass ich das nicht gleich mit angehängt habe.
    Anbei meine aktuelle Hyperion Konfiguration, die auch wunderbar funktioniert. Auf dem Arduino sollte eigentlich nur LEDStream sein. Mir ist das ganze schonmal komplett abgestürzt und da hatte ich dann nur LEDstream erneut hochgeladen. Das ganze Processing hatte ich nach dem Absturz nie mehr gemacht. Die LED Anordnung des bestehenden Ambilights wurde jedenfalls nach der Ersteinrichtung in Processing auch geändert und es funktionierte mit Hyperion trotzdem einwandfrei. Ich bin eigentlich davon ausgegangen, dass LEDstream auf dem Arduino ausreicht und das die restlichen Parameter von Boblight.conf / Hyperion kämen.


    Ist das nicht so?


    Kann ich die installierten Sketches irgendwie prüfen?


    Hier ist der LEDstream:
    [MEDIA=pastebin]vwN41vE9[/MEDIA]


    In Processing hatte ich die Anordnung damals so eingetragen und die ist obsolet:


    {0,8,9}, {0,7,9}, {0,6,9}, {0,5,9}, {0,4,9}, {0,3,9}, {0,2,9}, {0,1,9}, {0,0,9}, // Bottom edge, left half
    {0,0,8}, {0,0,7}, {0,0,6}, {0,0,5}, {0,0,4}, {0,0,3}, {0,0,2}, {0,0,1}, {0,0,0}, // Left edge
    {0,1,0}, {0,2,0}, {0,3,0}, {0,4,0}, {0,5,0}, {0,6,0}, {0,7,0}, {0,8,0}, // Top edge
    {0,9,0}, {0,10,0}, {0,11,0}, {0,12,0}, {0,13,0}, {0,14,0}, {0,15,0}, {0,16,0}, // More top edge
    {0,16,1}, {0,16,2}, {0,16,3}, {0,16,4}, {0,16,5}, {0,16,6}, {0,16,7}, {0,16,8}, // Right edge
    {0,16,9}, {0,15,9}, {0,14,9}, {0,13,9}, {0,12,9}, {0,11,9}, {0,10,9}, {0,9,9} // Bottom edge, right half


    Aber ich kann derzeit nicht sagen, ob das noch auf dem Arduino ist.


    LEDstream startet jedenfalls einen Test beim booten, der aktuell mit den alten WS2801 LED triggert, mit den neuen WS2801 nicht:


    // Issue test pattern to LEDs on startup. This helps verify that
    // wiring between the Arduino and LEDs is correct. Not knowing the
    // actual number of LEDs connected, this sets all of them (well, up
    // to the first 25,000, so as not to be TOO time consuming) to red,
    // green, blue, then off. Once you're confident everything is working
    // end-to-end, it's OK to comment this out and reprogram the Arduino.


    Die aktuell funktionierenden sind diese:
    https://www.adafruit.com/product/322


    Die neuen sind diese:
    https://www.aliexpress.com/snapshot...rderId=8015183854414146&productId=32259735265


    Wie könnte ich denn die neuen einfach auf Funktion Testen? Gibt es da einen einfachen weg?
    Ich hätte noch einen Arduino Nano rumfliegen


    Danke für Deine Hilfe



    EDIT:
    ich versuche jetzt auch mal die Hyperion Version von Adalight
    https://github.com/iLLiac4/Adalight_Hyperion
    das schaut sinnvoll aus :whistle:


  • You need a new sketch Arduino.
    In the line "#define NUM_LEDS" put your number of LEDs.
    In the line "//#define CLOCK_PIN" put your pin number Arduino.
    In Hyperion's settings LED Hardware -->.Baudrate --->change 500 000.
    This should work.

  • Hallo @TPmodding


    ich habe den Sketch angepasst und zuerst mit den alten LEDs zum Laufen gebracht. Vielen Dank für den Link. Das bestehende Hyperion funktioniert weiterhin.
    Im Anschluss habe ich den Sketch auf 160 LEDs angepasst und den Stripe angeschlossen. Dort tut sich jedoch nichts. Auch der Test springt nicht an. Es scheint mir, als ob die neuen LEDs einen Wackelkontakt haben ich habe das ganze mal aufgenommen:


    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Bis LED 157 kommt zumindest etwas an. Ich schätze ich sollte den Stripe jetzt einfach aufbrechen, final verkabeln und die einzelnen Stripes testen.

  • Hi Zusammen, BTF-Lighting hat bestätigt, dass der Stripe kaputt ist. Ich muss jetzt erst einmal neue LEDs besorgen, bevor ich weitermachen kann.
    Da ich jetzt eh neu anschaffen muss, würdet Ihr nochmals WS2801 empfehlen, oder soll ich lieber auf WS2812B (oder etwas anderes) gehen?


    In der Hyperion.ng doku steht, dass die WS2801 ein schlechtes Farbspektrum haben.


    Danke Euch!

  • bist bei ca 9,6A...sollte im rahmen sein...aber lieber ein stärkeres netzteil nehmen


    die 18w/meter benutzt er nur bei maximaler helligkeit aller leds...wird sogut wie nie vorkommen...aber ich würde bei soetwas immer auf nummeer sicher gehen

  • klar - macht natürlich sinn :facepalm: ich dackel.
    Aber die RGBNW 4000-4500K hattest du gemeint, oder? Die nennen das natur und nicht neutral. Von der Farbtemperatur sollte das jedenfalls kein Warmweiß sein.

  • Hi @TPmodding bitte entschuldige, dass ich so lange nichts von mir hören lassen habe. Urlaub mit den Kids war zu einnehmend.


    Ich habe die Lötstellen meiner 2801 LEDs neu verlötet worauf sie funktionierten. Mein neues Ambilight funzt nun auf Legacy Hyperion Basis. Lediglich eine LED am Ende leuchtet immer ganz leicht Blau und ich habe keine Ahnung wieso.


    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Hyperion.ng habe ich mit dem kodinerds Script unter x86 leider nicht zum laufen gebracht. Liegt womöglich an Alpha7... Die Web GUI ist einfach nicht erreichbar. Ich bleibe hier aber dran und werde es baldmöglichst Upgraden. Bis dahin baue ich mit den alten LEDs und einem RPi Zero eine zweites Ambilight für das Lowboard auf Hyperion.ng Basis. Hier sollte ich im Web auf jeden Fall etwas finden, was ich hinkriege.

  • Du kannst in hyperion (ng und classic) auch mehrere Instanzen anlegen.
    Dann benötigst du nur noch einen ESP (Wemos mini D1) mit WLED Software damit ist dein zweites Ambilight Optimal bedient.
    Hyperion mit ESP und WLED ist die beste Kombination mit den meisten Möglichkeiten, und kostet um 5 € dann auch wieder SK6812 RGBW-NW verwenden, dann passen die Farben Optimal zusammen, und bei SK6812 RGBW-NW sind die Farben ja auch ohne Farbabgleich schon sehr gut.


    Bei WLED kannst du auch das Netzteil 'begrenzen', so gibt es auch keine Probleme wenn man 'unterversorgt'.
    Du könntest die aber auch im Zuge des zweites Ambilight auch ein großes Netzteil besorgen mit dem du dann beide Stripes betreibst, oder oder...


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Hi @pclin Danke für den Tipp!! Das liest sich ja genial!! Wenn ich das richtig verstehe, kann ich das ganze mit diesem kleinen Teil einbinden...?
    https://www.makershop.de/plattformen/d1-mini/wemos-d1-mini/


    Ich hab ja auch noch das alte Netzteil der LEDs - da lässt sich das kleine Board sicher gleich mit betreiben.


    Ich werde mich mal durch die guides von SciLor durchwurschteln und sehen, wie weit ich komme. Wie ich mehrere Instanzen erstelle, kann ich ja hier entnehmen:
    https://hyperion-project.org/w…trolling-Multiple-Devices


    ...leck - ich liebe Hyperion halt täglich mehr

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!