Hyperion Home Assistant Switch Does Not Properly Toggle Lights

  • Originally I assumed this had to do with something in my configuration, perhaps it still is. I have 7 wled lights hooked up and calibrated to run off one of screen. They do not all reflect the same values, so forwarding ports or synchronizing them all is not an option. I added the switch to the Home Assistant using the recommended configuration here:


    light:
    - platform: Hyperion
    host: IP_ADDRESS


    2.0.0-alpha.7


    I noticed the default port recommended was 19444, but the [ports listed under the information tab shows both 19400 | 19445 under the Hyperion software.


    So I tried changing the port to 19445, which obviously did not lead to results as the port was mismatched.
    Changing it back to 19445, I began experimenting with the one WLED that was working. Here are my results, hopefully they help out / help get to the root of the problem(?)


    Expected: Toggling light off would lead to Hyperion to stop Syncing screen/effect.


    Result:
    Toggling the light on and off does not turn off the effects. It instead seems to change to a certain weird color pattern. A grey white with a couple of splotches in my setup, although results may vary. When toggled on again, the HDMI sync does not work properly unless you drill into the light menu and reset the effect to HDMI. I am unsure if this is intentional, but that's easy enough to fix in Home Assistant using the aforementioned implementation. It would be nice to have a toggle similar to how xLights is handled. When off, the lights return to whatever else is broadcasting. It would also be nice if the switch was either universal across Hyperion, or optionally would list the different light units as individual entities in HA. I am unsure if I talk to you about this, or the guys developing HA... But if I can get this worked out, I will be extremely happy!


    Thank you for all the hard work you do! This project is amazing.

  • I am experiencing the same. Having only just configured my Rpi with Hyperion (which works great BTW - Thank you) I can't offer much help towards a cause or solution though.

  • Hi,


    there are a few things you need to consider to get this working.


    Here you can find some workarounds and even a fork of the HA hyperion component that works better with Hyperion NG:


    https://github.com/home-assistant/core/issues/35464


    Furthermore you have to add the right priorities to configuration.yaml like this:



    - platform: hyperion
    host: xxx.xxx.xxx.xxx
    priority: 128 #### HA DEFAULT
    hdmi_priority: 240 #### MATCH HYPERION DEFAULT


    When you do this than you can apply effects from HA and if you want to switch to USB capture you have to select the effect to HDMI. That works even without the fork.


    I made a simple automation that when switching off sets the effect to HDMI automatically. So I can use color effects and when I switch them off the automation is triggered and sets the mode to HDMI. If there is a signal it will do the ambilight if not it switches off via signal detection. Thats pretty much all I need.


    I hope that helps you to get it working.


    BR
    René

  • i am still experiencing this issue with the newest home assistant


    when i select an effect the LEDs light up accordingly. However, there is no way to return to usb/platform capture. i can select USB capture in the dropdown menu from the entity card suggested by home assistant but that only switches USB capture off.


    in general the integration seems kind of unstable. it constantly loses connection(?) to the hyperion instance as the added devices randomly shows up as unavailable in home assistant.


    am i doing something wrong here? still quite new to home assistant


    any help much appreciated



    :EDIT


    figured out a workaroud in case anyone is having hte same issue:



    create a script as follows

    Code
    service: light.turn_on
    target:
    entity_id: [HYPERION ENTITY ID]
    data:
    effect: V4L



    -- this will switch hyperion source selection back to "effect: V4L" which is USB cap

    consult the configuration of hyperion in home assistant for the labels of other grabbers (i.e. GRABBER is platform i suppose)

    Edited 5 times, last by pho08: Merged a post created by pho08 into this post. ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!