Help capturing MJPG

  • Hi guys, this is my first time using rasperypi for ambilight purposes


    I've been playing around a lot with the previous hyperion, now I'm on hyperion ng using the hyperian image baked on raspberry pi 1


    First I was using a HDMI2AV module + a video grabber AV to USB, but the resolution on YUYV was very low compared to the MJPG one.


    Now I have purchased an HDMI capturer which comes with higher resolutions, but still the one on MJPG comes with way more fps.


    I was wondering if there's any way to force the MJPG format, in previous hyperion I was able to modify the resolution by using a prestart command on the service, but in hyperian ng everything gets overwritten everytime I start the service.


    I tried modifying the `hyperion-v4l2` and `v4l2-ctl`, I have no idea about their differences to be honest don't know which one is used in which case, I tried both, `hyperion-v4l2` doesn't support MJPG and `v4l2-ctl` doesn't seem to persist as its reseted after service starts.


    I'm checking the current value with `v4l2-ctl --get-fmt-video` and setting the value with `sudo v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=MJPG`


    Thanks a lot in advance.


    PS: sorry for the probable wrong prefix on the thread

  • *BUMP*

    I've the same problem: HDMI-Grabber with Loop Out: MJPG only.

    (on a Pi Zero - everything directly connected -- FireTV-->HDMI_Loop_Grapper-->TV )


    already searched the internet/forums and read a post from 2017 that 'gstreamer' can help. whatever it takes, can this be enabled ??

    (I am on Hyperbian 2.0.0 alpha 9)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!