HDMI Grabber issue

  • Hello, first I want to start with saying thank you to your amazing team for creating this beautiful software. It works amazing.


    My setup:
    Raspberry pi 3 b+
    Ws2812b connected to gpio18
    Hdmi to hdmi/usb splitter
    Xbox one as source
    15a power supply


    Everything is working great, the leds are perfectly synced with the tv and colors are as accurate as they can get.
    My issue is that when I turn on my Xbox first and then I turn on the raspberry the leds just strobe white. When I go into the hyperion web there is no signal from the usb grabber, sometimes when I disable and enable the instance or disable and enable usb grabbing it fixes the issue but not always.
    If I turn the raspberry pi first and then the Xbox then the lights always work.
    I'm wondering if someone has run into this issue before?
    It becomes annoying because I have hyperion connected to habridge and if I use voice command to turn hyperion on after I have my Xbox on it just doesn't want to capture the screen.

  • Your setup is clear, but how is everything connected to the TV?
    The loop out of the grabber is only suitable to a limited extent for Xbox


    1080P 30fps, DON'T work for HDCP2.2


    Regards pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited 2 times, last by pclin ().

  • Your setup is clear, but how is everything connected to the TV?
    The loop out of the grabber is only suitable to a limited extent for Xbox


    1080P 30fps, DON'T work for HDCP2.2


    Regards pclin


    hey thanks for reply.
    My xbox goes into the hdmi to usb/hdmi splitter and usb is connected to raspberry and hdmi goes out to the tv.
    The thing is that it all works fine as long as I turn raspberry pi first, If I turn on my xbox and watch something on the tv and then decide to turn on raspberry it doesn't work. I have to turn off the xbox and then it works.
    here I made a little diagram of how I have it all connected.


  • This is not a good solution
    Xbox then only delivers 1080p 30fps. :(


    Regards pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • The switch on behavior that you describe I can not understand, this should not normally have any effect.
    The RPI is only connected to the grabber via USB.
    So neither EDID data nor HDMI handshake can play a role.
    Instead of restarting the xbox make a reconnect of the HDMI connection


    The EDID data of the Grabber transmit to the Xbox 1080p 30Hz, no HDR and HDCP 2.2.
    So Xbox delivers no more than 1080p 30Hz without HDR and HDCP 2.2.


    Regards pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever


  • Ok so just unplugging and pluging back hdmi from Xbox also fixes the issue.
    Do you think there is any way around it?

  • Use a splitter with HDR and HDCP 2.2 support, and not the loop out of the grabber.


    Regards pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!