Ambient light intermittently ON and OFF

  • Hi all,


    I have Hyperion installed on a Raspberry4 and the "ambient light effect" does work, but it intermittently goes OFF and ON with variable intervals of a couple of seconds. This also happen when the image is a static one.


    The strange thing is that this does not happen when i choose a fixed colour or an "animation" for the LEDs (example: home assistant entity), as in that case i do not have any problem. So this makes me think that is a grabber/video configuration problem. Here is the hyperion configuration:



    I tried to update hyperion, restart the raspberry and it seems to work for the first couple of minutes, but then the problem is there again.
    I'm able to take a grabber screenshot, but the logs tells me the following:


    Any help? Here a picture of my setup. Honestly, it started since i moved the video grabber USB stick from that port to another for space issues. But i hope it's just a coincidence, i didn't really tried it a lot before.

    E
    dit: sorry, i noticed that i wrote in the wrong section, i wanted to fost in Software. Could this post be moved?

  • Frame's size mismatch for YUV (where framesize is constant) indicates problem with v4l2 driver caused mostly by hardware (grabber, usb bus, voltage jumps et). It can happens on the start of video process capturing during initialization but not after. Upgrading to Hyperion.NG may or not help. Check dmesg.

  • Ok, thank you all.
    I've tried to disable the blackborder detection that i turned on, modify other settings to the default ones but nothing.


    Actually i didn't now about this new build. I'm not an expert at all in linux compiling, I simply removed Hyperion from the Hypercon interface, the run this script (since i cannot install Hyperbian as I do have other stuffs in my Raspbian):

    Code
    wget -qN https://raw.github.com/hyperion-project/hyperion.ng/master/bin/scripts/docker-compile.sh && chmod +x *.sh && ./docker-compile.sh -i rpi-raspbian


    Apparently it all went well..



    But now? I guess i do have to start something somewhere but I'm not able to figure out what/where from the documentation (https://docs.hyperion-project.…on.html#web-configuration).
    I cannot reach the Web UI through that port.


    Thanks in advance for your patience toward a noob

  • i didn't run the script in docker myself, so i think it installed itself in a virtual container.


    run the hyperiond service in terminal, or doubleclick the hyperiond and run/execute,
    after this you can reach (local adress) :8090


    in terminal go to direction of folder contains by cd name and enter,
    go back by cd ..
    if you arrived in folder then execute hyperiond

  • Did it! Had to sudo ./hyperiond and then install many libraries that were missing.


    After a short setup, I made it work in Hyperion NG. Weird thing is that also here the ambientlight effect was going ON and OFF, and the V4L2 row was indeed appearing and disappearing from this list below. As if the grabber was removed and inserted, i guess.

    After a while, it just started to work. I even switched back to Hypercon, stopping Hyperion NG, and it worked also there. I don't know, it's still working as I'm writing, but i'm just waiting for the problem to present again so that i can point out that it is an hardware one!


    In the meantime.. does anyone use it with Home Assistant? One thing that I find annoying is that when i select the HDMI effect from the entity, after a while the icon appears as if LEDs are OFF, while the ambientlight is still going. This does not happen with fixed colours or other "lamps" effect.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!