Hyperion NG works but not on reboot or cold start

  • Hi all,


    I have been using Hyperion Classic on a Intel HTPC for a fair while now without any issues.I checked the forum and saw that NG has progressed an awful lot - I am not a coder and a complete noob when it come to Linux but I am capable enough to have gotten Hyperion Classic installed and working :).


    I now have NG working and all the leds operate etc and the ambilight effect in Librelec is great.


    The issue I have is that if I power off the HTPC I get the RGB sequence but no rainbow effect or any ambilight within Kodi.


    The server doesnt appear to be working as I cannot connect via phone app but if I use the web gui I can manually turn the leds on.


    I am using APA102 Led's and the kit I originally had was a Lightberry kit that has been modded to have more led's so it uses an Arduino.


    I have messed around adding various Hyperion Kodi add-ons and was wondering if these could be interfering with the system - all uninstalled now I must add.


    Thanks

  • did you turn-off smoothing @ remote controll?


    if you turn it off and lights work again then its a bug in controller part and known by dev's now.

  • Hi Jereon, thanks for the reply.


    I have just tried turning off smoothing and done a reboot and also a cold boot. I still have to turn the leds on manually to get it to work.

  • OK I have done some more researching and have attached the log file to this post.


    I can see that the Arduino is recognized but then there appears to be a second instance of it where it says its been disabled. I don't know what to do next


    (ERROR) Device disabled, device 'adalight' signals error: 'Invalid serial device name: [ttyACM0]!

  • The error indicates that your Arduino is not found under the name of "ttyACM0".


    Give it a try with "auto" and see, if the device identifies itself.
    If yes, you will find in the log the name used:


    Code
    2020-11-11T08:46:44.079 hyperiond LEDDEVICE    : <INFO> found serial device: ttyACM0


    Note: Mine is under "ttyACM0", but you should see a different name.


    upload_2020-11-11_8-49-36.png

  • Thanks for the help, I’ve tried changing it to auto but get a different error now. Hope that works never used paste in before :)


    [MEDIA=pastebin]NjV60p71[/MEDIA]

  • The error indicates that your system does not provide any serial devices... or the device is busy


    Code
    2020-11-11T08:31:49.324Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'adalight' signals error: 'No serial device found automatically!'


    Could you please post more details about your system.
    Copy/Paste the System Info from "about hyperion"


    In addition, could you do a ls -la /dev/ttyp*


    If you running on an rpi, do you have Bluetooth on?

  • Sure here you go. This isn't on a Pi, its a Intel system I3-6320 - no bluetooth on this either


    Hyperion Server:
    - Build: (HEAD detached at 08909b8a) (Paulchen-Panther-75963ca9/08909b8a-1600115237)
    - Build time: Sep 14 2020 20:32:45
    - Git Remote: https://github.com/hyperion-project/hyperion.ng
    - Version: 2.0.0-alpha.8
    - UI Lang: auto (BrowserLang: en-US)
    - UI Access: expert
    - Avail Capt: v4l2,framebuffer,x11,xcb,qt


    Hyperion Server OS:
    - Distribution: LibreELEC (official): 9.2.6
    - Arch: x86_64
    - Kernel: linux (5.1.16 (WS: 64))
    - Browser: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0


    I just tried the command you asked me to input and it tells me - No such file or directory

  • Looks like you have two USB devices


    crw-rw---- 1 root dialout 166, 0 Nov 11 13:09 /dev/ttyACM0
    crw-rw---- 1 root dialout 166, 1 Nov 11 13:19 /dev/ttyACM1


    Have you tried configuring "/dev/ttyACM1" ?


    Or could you execute the following commands? Does one come back with "Ada"?


    1.
    cat /dev/ttyACM0


    To stop press, ctrl-C


    2.
    cat /dev/ttyACM1


    To stop press, ctrl-C


    3.
    dmesg | grep usb


    4.


    dmesg | grep tty


    Please share the output...

  • I tried changing the setting to "/dev/ttyACM1" as you suggested and it made no difference.


    Your suggestions though made me think about what else I had connected via USB, I have a


    Flirc
    Logitech dongle for a K400r keyboard/mouse combo
    Pulse 8 CEC
    The USB lead from the Arduino


    I disconnected everything except the Arduino and it works! I get the rainbow on reboot and the LEDs come on as they should. I added back in the USB devices one by one and kept checking by rebooting and it all worked until I added the Flirc.


    I am happy to try what you have requested in your post above if it helps to diagnose the issue though? I expect you would like to know where the issue lies?


    Thank you for all your help with this.

  • No I haven't yet, I was wondering if I should try using different USB ports as a test? Would it be a conflict on the USB channels? I wonder if I should speak to Flirc?

  • I’m going to mark this as solved, for reference I am now using a nodemcu and I also have the flirc plugged back in and that is also functioning as it should. I don’t know if it was a conflict with the original lightberry arduino or not. I have looked on the flirc forum but haven’t found anyone else with the same issue.


    I have to be honest the nodemcu is a great piece of kit! Seems ever so responsive and was an absolute doddle to setup. It even links to Philips hue.


    Thanks to @Lord-Grey & @jeroen warmerdam for the help

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!