Raspberry Pi 1 Model B with HDMI to USB Video Capture Card

  • Hi All,
    I've got Hyperion up and running on a Raspberry Pi Model B (old unit)
    and an GOODAN Audio Video Capture Cards Connected to a testing laptop.
    For power, I'm currently using a 5v 4 amp charger. (No LEDs have been connecting yet)
    I want to get confirmation that the video capture card is working but when I open Hyperion UI and click on the "Live Video" option I don't see anything in there.



    Can you please help me figure this out?
    Thank You
    -Los

  • Hi NeeeeB, Thanks for your reply!
    From the laptop I can project to another monitor via HDMI is that is what you are referring to? otherwise, I'm not sure of a screen-sharing setting from my laptop and it will be helpful if you can point it out.
    I forgot to mention that I used the same laptop + video capture and plugged it into my desktop. I was able to capture the video from the laptop using OBS Studio, so the card seems to be working OK in Windows 10 but this is what I get from Hyperion UI
    Attaching Device info.



    upload_2020-11-13_11-6-59.png

  • If you can use a projector with that HDMI output then the screen sharing option is enabled.
    You might wanna try and set Video standard to automatic and resolution to something smaller, like 720*480 for example.
    I suspect that your Pi is not powerful enough to display the preview at such a high resolution (1920*1080).
    I had that capture card too and even with a Pi3 live preview was buggy.
    I'm sorry but I can't help you further on this.
    Maybe someone else who reads this ?

  • **Update**
    I was able to pull a video from the USB to HDMI video capture using FFmpeg utility but I still can't see the screen via the LED Visualization
    upload_2020-11-13_15-8-24.png


    Should I ignore the screen and go ahead and wire the LEDs at this point? or the fact that my video is not showing in the screen above indicates a possible issue in my setup?

  • Solved!
    It looks like Hyperion did not like the source to be "automatic" under the USB Capture settings.
    Instead, it needed the correct Device path: /dev/video0 and now I can see the beautiful pixelated screen :)



    upload_2020-11-13_15-30-10.png


    Hope this helps someone in the future. Step 1 has been completed for me. now I'm ready to wire up those LEDs. Can't wait!


    Thank You,
    -Los

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!