Ambilight Setup mit Synology NAS?

  • Liebe Gemeinde,


    ich hab mir schon einen Wolf gegoogelt, aber konnte keine konkrete Aussage finden.


    Zu Hause steht ein Synology NAS DS 718+ mit der schönen Funktion von virtuellen Maschinen und Docker.
    Ich würde gerne mein Ambilight Setup damit aufziehen, sofern das überhaupt möglich ist?
    Auf dem NAS läuft der PLEX Server und nun auch der Home Assistant (im Docker).



    Meine Fragen:
    - Läuft auf dem NAS nur die Verwaltung und LED Steuerung per Hyperion?
    - Einbindung über ein WLED Board und Wifi ins Heimnetz und zu Hyperion?
    - HDMI Signal über Splitter und Videograbber oder SCART OUT, per USB ans NAS?


    Ich will diese Variante nicht unbedingt übers Knie brechen, dachte mir aber, ich kann evtl meine vorhandene Hardware nutzen?

  • Jepp, sorry :whistle: Wusste nicht ob ich mit Englisch mehr Resonanz bekomme und der deutsche Part hier eher nur ein Ableger.
    Vll kann ein Mod das zusammenführen oder schließen :)

  • Ich habe exakt das gleiche vor. Habe auch eins Synology DS 718+. Mein Problem ist nur, finde zwar mit lsusb den Grabber, aber unter /dev wird kein video0 erzeugt. Mit dmesg sagt mir das system hiddev0 und in /dev/usb wird aber ein hiddev8 erzeugt. Ich glaube die Treiber fehlen einfach auf dem NAS.

  • Ich hab hier mal weiter geantwortet:
    [INDENT]https://hyperion-project.org/t…-with-synology-nas.10973/[/INDENT]


    Muss das NAS die Treiber haben? Wenn das Gerät nur durchgeschleift wird, fehlen ja eigentlich die Treiber nur im Docker Container, oder?
    Daher also wohl über die Kommandozeile die Treiber im Container nachladen.


    Alternativ, statt Docker eine Virtuelle Maschine anlegen, hier dann ein OS mit Oberfläche und dann kann man darüber besser agieren? Verbraucht vermutlich aber mehr Ressourcen.


    Wie hast du Hyperion am Laufen?


    Edit:
    Bei mir siehts ähnlich aus. Es ist was da, aber nicht unter dev/video0, nur als dev/usb/hiddev8
    # lsusb
    |__usb3 1d6b:0002:0404 09 2.00 480MBit/s 0mA 1IF (Linux 4.4.59+ etxhci_hcd-170202 Etron xHCI Host Controller 0000:02:00.0) hub
    |__3-1 534d:2109:2100 ef 2.00 480MBit/s 500mA 5IFs (MACROSILICON USB Video ffffffdbffffffbeffffffdaffffffb3)


    edit2:
    Vm läuft
    Ubuntu läuft
    Hyperion läuft
    v4l2 installiert
    dev/video0 vorhanden
    2 Kanäle vorhanden
    Später testen ob Video Signal ankommt


    (meine Vermutung: im Docker Container fehlen paar Module etc für das Video Signal)

  • Hab es aufgegeben. Docker ist da wohl nicht geeignet.
    Über eine VM mit Ubuntu funktioniert es so weit gut. Fehlt noch die Lichterkette aus Fernost, dann weiß ich auch obs in der Praxis funktioniert

  • Leider habe ich es auch nicht hinbekommen, gebe es auch auf. Ich habe mir jetzt einen Pi 4 bestellt, damit kann ich meinen HDMI Grabber auf Full HD stellen und habe somit weniger Bildrauschen und fast kein flackern mehr auf den LED's. Meine NAS hätte eigentlich noch genügend Ressourcen gehabt, aber naja.......

  • Bin leider noch nicht ausreichend mit Docker bewandert, aber so weit ich herausfinden konnte, wird da ja kein OS simuliert/virtualisiert/emuliert.
    Und da im Synology Kernel die Treiber für snd_usb_audio und uvcvideo fehlen, wird keine USB Video Stick erkannt, bzw dieser kann nicht verwendet werden.


    Abhilfe für mich war hier nun, über Synology VMM eine Virutelle Maschine mit Ubuntu zu erstellen und darin dann Hyperion zu installieren. Der Stick wird direkt erkannt und liefert das Videosignal.


    Morgen kommt endlich der SK6812 LED Streifen, dann kann ich das komplette Setup testen.


    Evtl gibts ja auch Video-Grabber die per LAN oder WLAN funktionieren um nicht auf die USB Schnittstelle und Treiberprobleme gehen zu müssen?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!