Knipperende ledstrip

  • Goedemorgen allemaal,


    Nu ben ik pas begonnen met mijn amilight project en heb ik nog 1 probleem.
    Ik heb een raspberry pi 4, WS2812B ledstrip (200 leds in totaal) en een ESP8266 (nodeMCU V2)


    om mijn grabber te laten werken heb ik hemel en aarde moeten verzetten aangezien de mainbranch hem niet kon vinden..
    Komt wel tevoorschijn met lsusb (enkel de vendor ID's) maar geen naam, de MJPG branch versie werkte wel weer perfect enkel kan ik bij deze helaas geen platform capture doen.


    Nu zit ik met het volgende dat de ledstrip random wat flikkeringen krijgt van andere kleuren.
    Ik had eerst het vermoeden dat het de nodemcu was die zijn netwerk verloor, dus heb een extra AP dichtbij geplaatst en zie dat deze nu op 100% signaalsterkte zit. probleem blijft hetzelfde.
    de ledstrip voed ik aan het begin met 5V , data en GND , op het einde nogmaals met 5V en GND.
    Zou het kunnen dat de datakabel te lang is? (dit is ongeveer een 25-30cm)


    Ik zou liever niet GPIO18 willen gebruiken van de Pi aangezien deze in een argon one case zit en ik deze in het zicht heb zitten voor meer gebruik (retropi etc)

  • Solved : tijdens het verschuiven van de tv zag ik de LED's heviger knipperen. het enigste dat nog niet met dubbelzijdige tape vastzat was de voedingskabel naar de leds. hiervan was er 1tje intern "onderbroken". Kwam er helaas tijdens het meten niet uit omdat hij mooi 5V aangaf. voedingskabel vervangen en werkt nu mooi.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!