raspberry pi 3+ - hyperion

  • External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    i have follow a video from youtube and i have put the last Hyperion 2.0.0-alpha.9 but i have some issues when i unpackage the deb file from this version
    https://github.com/hyperion-pr…eleases/tag/2.0.0-alpha.9
    dpkg : error processing package (--install)
    Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)


    Since i can t unpackage this version i put the same version that is in the video Hyperion 2.0.0-alpha.7 with sucess, i be able to unpackage without errors.


    Right now i have the 2 version on my raspbery pi 3+, and dont know i i will have somes issues when i connect the leds, so my question is if i can erase the alpha 9 version from my raspbery pi


    pi@raspberrypi:~ $ dir
    Hyperion-2.0.0-alpha.7-Linux-armv7l.deb
    Hyperion-2.0.0-alpha.9-Linux-armv7l.deb


    Thank you on advanced

  • This is my dasboard from hyperion


    Hyperion status: On
    Platform: Raspberry Pi
    Controller type: ws281x
    Instance: gpio 18
    Ports (flat|proto): 19400 | 19445
    Your Hyperion version: 2.0.0-alpha.7
    Watched version branch: Stable
    Latest Hyperion version: 2.0.0-alpha.9

  • well going with what you posted above the version 9 didn't install anyway because you didn't run it as root (Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)) if you had ran that as root or with sudo it would have installed alpha 9

    Code
    rm Hyperion-2.0.0-alpha.9-Linux-armv7l.deb


    So all you would need to do is remove the alpha 9 .deb file but wont do any harm if left there, providing space isn't an issue

  • i run the root by putty. i am sorry but i am a newbie at this and i don't understand very much, its my first time that i do this.


    so next time i need to run as root i type sudo su? ( i have doing a search on the internet :) )

  • yeah man, Although you need to pay close attention to the commands you are running if you are not copy and pasting them, leaving out parts or adding in additional bits can have serious consequences if not used correctly, Luckily you were only trying to install something and as you didn't have permission to do so it done nothing.


    https://docs.hyperion-project.…on.html#supported-systems


    It looks like you have alpha 7 installed, go with that for now, It is installed and appears to be working so see if you can get your LEDS setup, play around with some settings then If you want a blank canvas pull the SD if in any doubt and try it again and install the latest, chances are any errors you come up against will already be answered in here somewhere, the more you do it the easier it becomes and it sounds like you already made progress :thumbsup:

  • Since I m using a amazon fire stick 4k when I see netflix movies my ambilight system will be working? I think I have read something regarding ambilight doesn t work with netflix because drm.


    If so can i do in order to work ambilight with netflix?


    Thanks in advanced

  • Anyone can help me regarding netflix working with ambilight?


    Finally I have receive my LEDs strips but I have a doubt about the placement the LEDs strip.
    When we are at the hyperion page led layout in order to paste the 1st led(please se the picture ) the image showing is when we see the tv from the front?
    If we see it from the front the 1st led it will be on the top right corner ??

  • Congrats @filipe teixeira yes that pic is the front of the tv, If you look in the classic Layout section, that may be the easiest way for you to define your layout, you basically tell it how many you have at each side then the use the input position to tell it where to start from, so rather than setting it up how Hyperion tells you, you basically do it how you want then tell Hyperion where it starts from via the input position, and use the reverse direction if you have the rotation going the other way.


    Still no use to you with the whole netflix situation tho, sry man

  • Ok so I have receive my power supply today and I have install my LEDs (60 leds/m)on de back of my tv, but the LEDs dont turn on.
    So I think I don't have enough power, I have one power supply with 5v 10a and I have 188 LEDs on total. 60 on the top 60 on the bottom and 34 on the left side and 34 on the right side.


    Do you think I need another power supply with more power??

  • funny that you should ask this, i don't know if your WS2812B are the same as mine but I checked the other day and my LEDS in full operation didn't consume more than 4 Amp and i have 10 LEDS less than you so you should be ok using the 10A


    You may need to inject some extra power but you should be able to get the majority of them lit using your current setup


    If you go into Hyperion GUI or install the Hyperion app on your phone, can you set effects or set the LEDS to a specific colour? Does that work?

  • but you have no data connection on that line, so how will it know what leds to light up?


    did you try the effect from the GUI or install the smartphone app and set a solid colour, Its hard to provide support while jumping about all over the place without ruling things out as yes it could be the PSU or barrell connector plus a ton of other things, even if your PSU is underpowered you would expect that very first section of LEDS to be working beautifully.


    Out of shear curiosity what do you get when you run this command on the pi

    Code
    uname --m
  • What I don't realize is why when I turn on only the LEDs to the power supply the LEDs dont work. Maybe it's a problem with the led strip ,because the connection are good and when I go to the live video capture I see the image

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!