LED Stripe lights up in the right color, then goes back to white

  • Hi guys, I am trying to get an ambilight setup running with the following hardware:

    • Raspberry Pi 3
    • LED-Stripe digital WS2811 (LK41ws-IP67) (1 data cable, 1 ground cable - NO clock cable)
    • HDMI 2 AV Upscaler (not entirely sure I need that?)

    I have connected the LED stripe with the Raspberry pins 19 and 20, opened HyperCon and installed Hyprion on the Raspberry with it.

    Under "Hardware", when I choose "WS281X (RPi1,RPi2,RPi3)" , send the config file and start it, the LEDs start glowing white. No rainbow, no other colors.

    When I pick "WS281X-SPI" and start it, then the rainbow-effect starts running BUT only for 1 second - then it goes back to white. Same thing when I pick a color with the SSH Colorpicker (color lights up for 1 second - back to white).

    Does anyone have an idea what could cause such behaviour? I'm getting kinda desperate here.

    Thanks :)

  • Thanks for your reply!

    I have installed the latest version of Hyperion.ng

    But the issue doesn't change. As soon as I choose "ws281x" as controller type, nothing happens.

    If I choose ws2812spi, the LED stripe lights up in the chosen color for 1 second, then goes back to white-only.

  • I remember I have already read about similar problem in forum, try to search ...

  • steveniclas

    Changed the title of the thread from “Raspberry 3 - Trying to setup Hyperion” to “LED Stripe lights up in the right color, then goes back to white”.
    • Official Post

    steveniclas "But the issue doesn't change. As soon as I choose "ws281x" as controller type, nothing happens." What does the Hyperion log say?

    What does the hyperion log say?

  • steveniclas you know that ws281x and ws2812spi use to different gpio pins on the rpi?

    No, I didn't know that. I am a total beginner with all this. After some researching, I changed the connection cable to GPIO18 (pin 12 on RbPi), because that's the one showing up in Hyperion when selecting ws281x. Does that make sense? Now, I can't get the LED stripe to turn on at all, though.

    This is, as asked by Lord-Grey, the error that shows up in the log:


    2021-03-14T15:31:45.580Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: mmap() failed'

  • Changed to root.

    Now, when I save my configuration in Hyperion, nothing happens. Log shows this:


    2021-03-14T16:14:15.469Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:

  • The LED stripe only has a data cable, no clock.

    you can run it from PWM or SPI,

    because you said you are using a WS2811 before.

    mostly everyone connects to PWM (GPIO18) > if you do that then switch off audio in config.txt

    # Enable audio (loads snd_bcm2835)


    maybe you also need a logic levelshifter after this to boost the data signal

  • You need to run hyperion as root with this configuration (device 'ws281x) PWM

    go to your terminal

    sudo nano /etc/systemd/system/hyperiond@.service

    Remove the User sessionline and save with CTRL+O and exit CTRL+x.

    Don't forget to reboot the Raspi after this

    Looks like I failed in making Hyperion run on root before - because this did it.

    It's now working like a charm - thank you guys a lot! :)

  • Hi everyone, sorry to write again in this post but I'm having a similar problem:
    I have got mi RPi3 with hyperbian, WS2815 strip with common ground to the RPi3, and data wire into GPIO 18.

    NONE of the LED turn on, not even from the android app.

    However, when I tried changing from GPIO 18 to GPIO 10, I got the strip to light up, but only in bright white. When trying to change the color from the android app, the color (or the effect) changes for one second, and then turns back to bright white.

    I tried running hyperion as root insitead of pi (I'm a beginner user so I'm not 100% sure I'm doing this the right way), and this didn't solve my problem.

    I also tried putting the audio kernel module in the blacklist as stated here : https://github.com/jgarff/rpi_ws281x#pwm
    But got no luck at all.

    Could it be that I need a logic level converter?

    Please help me I'm desperate, and sorry for my ingorance, this is my first raspberry project.

    Thanks everyone!

  • Hi Unavailable77..

    hope you and everyone here iis safe and your families aswell.

    I running to a similar problem, I HAVE LED WS2815 that lights up in the right colors from the image capture or the colors I choose in the app, then goes back to white, Im running Hyperion as root and I'm using a Logic level converter for the pins GPIO 10 and GPIO 11 what could be ?,

    I got Rpi 4


    Ws2815 (12v ws2812B) 300 LED

    Im really new in this But Iam a good listener Thanks and advanced

    the update fixes it Thanks everyone I just have to used the GPIO18 ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!