RPi4 - Arduino Uno - SK9822 | Flicker/Flash of Inconsistent Colors

  • Hello,

    I am running the setup in the title with 208 LED's. I get an inconsistent flicker/flash of another color. The following link gives a good idea of what it looks like. https://drive.google.com/file/…YP_pvaKg/view?usp=sharing

    The screen would be a solid green but get a flicker of red on all the LED's and go back to green. The video is a bit highspeed but provides a good example of what is happening with normal viewing.


    I've changed the brightness settings on the interface and that helped but didn't alleviate the problem. Smoothing is enabled with a decay of 02, I made that change after the video was taken with no positive result. Black bar detection is enabled as well.


    The adalight sketch I uploaded is the most recent version from the git (5 days ago?). The MAX_LED's are set to 208, LED_TYPE SK9822, 3/4 wire are commented/uncommented out as appropriate, color order is GBR, and serial rate is 115200.

    Hyperion web configuration: Led Hardware is adalight, RBG light order, matching baud rate, and the output path is /dev/ttyACM0.


    To troubleshoot I uploaded an adalight sketch to the Uno and controlled the LED's from Prismatik. This resulted in a perfectly working configuration (minus the lights my wife stepped on when I was testing it). Establishing the problem is something between the RPi and the Uno. I uploaded HyerBian to a spare SD card and got the same result, so I've reverted back to my config.


    Any help is appreciated, I've been waiting to watch The Expanse S4 until this thing is up and running!

  • what i would do first, check your SPI connections>> are they soldered to the Arduino?


    did you ground (GND) everything from ledstrip to the Arduino to the PSU? If not ( correctly) then you can have really weird behaviours in the leds.

  • The connections are not soldered but they worked fine when using my PC to control it with Prismatik there were no problems. Any info on how I would solder it to the Uno?


    The PSU powers the LEDs and Uno. The 5V and ground from the Uno are connected to the LEDs.

    • Official Post

    SO with the same hardware, nothing changed/plugged different it works, only with different software the flashing occurs, right?

  • The only hardware that changed was switching a RPI4 for a laptop.


    I tried using HyperHDR with the same result.


    Kind of like HyperHDR because it makes use of the multiple cores.


    I don't know what the problem was, but it was related to the Arduino and RPi4. I ran HyperHDR on my laptop and used the capture device, worked perfectly.


    My solution has been to upgrade from an Arduino solution to a WLED solution.

    Edited once, last by TPmodding: 2 Beiträge von Hans5849 mit diesem Beitrag zusammengefügt. ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!