Projektvorstellung: Hyperion NG verpackt in einer Box

  • Quote from sorted

    Mein Pi bekommt plus 5v (pin2) und GND (pin6) von Netzteil am GPIO. Den Pi an 2 Pins mit 5v zu versorgen macht wenig Sinn. Das dein Pi meckert ist allerdings komisch, da dein Netzteil ja reichlich dimensioniert ist und der Pi mit 3A zufrieden sein sollte und diese auch bekommen müsste.


    ok danke dir für die Info, hab ihn zwischenzeitlich an beiden Pins angeschlossen, das selbe Problem.
    ich vermute, dann liegt es vielleicht an den kabeln die ich benutzt habe (jumper kabel), werde die bei Gelegenheit mal mit anständigen Kabeln ersetzen.


    Der Shelly läuft soweit auch, nur die Einbindung in ioBroker fehlt noch, dass kommt dann aber zum Schluss.

    Der HDMI-Splitter läuft getrennt von der Konstruktion und bekommt Strom über den USB vom TV - funktioniert bestens. Somit kann meine Frau problemlos TV schauen ohne dass das Ambilight bzw. das Netzteil erstmal eingeschaltet werden muss.


    In der Vorschau bei Hyperion.NG gibt der WisFox mir das Bild vom HDMI-Splitter auch aus, das hat soweit auch alles geklappt :) allerdings blieben die LEDs zuerst dunkel.
    Hab ein wenig gegoogelt und hier im Forum geschaut und auch noch ein bisschen rumprobiert. Letzter Stand ist nun, dass der Regenbogen-Effekt am Anfang kommt aber unmittelbar danach die LEDs auf weiß schalten. Könnte evtl. mit den WS2813 zu tun haben, morgen mal weiterschauen was es hier auf dem Forum noch für Lösungsansätze gibt, wird aber sonst ein Thema für einen eigenen Thread.


    Zumindest bin ich schon mal froh, dass der Regenbogen-Effekt am Anfang kommt. Sollte ja eigentlich ein Zeichen sein, dass die Strom bekommen und die Lötarbeiten soweit OK sind und der Pi die LEDs mit Daten versorgen kann (es war doch schon etwas kompliziert, die 2,5mm² Kabel am Stripe anzulöten so dass es hält :D die Kabel sind ja schon fast dicker als der kontakt selbst).

  • moin sorted,


    nach anfänglichen Problemen mit dem Vis-Adapter auf dem NAS (keine Schreibrechte) konnte ich das Problem grad lösen.

    Script mit Blockly nachzubauen hat auch prima geklappt, war garnicht mal so schwer (dank deiner Vorlage) - auf jeden Fall interessante Materie das ganze System.

    Das Script schaltet nun so wie von dir beschrieben - vielen Dank für deine Projektvorstellung und der genialen Lösung! Ein dickes Lob von meiner Seite aus nochmals!


    Was jetzt tatsächlich noch interessant wäre, wäre wenn der Onkyo- oder LG-Adapter erkennt, dass HDR-Material wiedergegeben wird

    und dann zwischen den einzelnen Hyperion-Profilen (HDR/SDR) automatisch hin- und herschaltet :D


    Jetzt werde ich mal sehen, weshalb bei den ersten 80 LEDs jeweils nur jede 2. LED angesprochen wird - bin da leider noch auf keine Lösung gestoßen.

  • Echt nice

    Auch von mir ein riesen Lob.

    Bin grad auch bei der Planung alles in eine Box zu packen.

    Dachte fürs an und ausschalten an einen 1 Kanal RoboMall Kanal Relay 5V 230V der an die USB Schnittstelle vom Fernseher angeschlossen wird. Fernseher an - - > 5V an Buchse und Hyperion startet. Wenn der Fernseher aus ist sollte Direkt alles hart geschaltet werden (ob das so gut ist?)

    Was haltet ihr davon?

  • Was haltet ihr davon?

    So hab' ich das auch gelöst. Löte aber besser noch einen 1kOhm-Widerstand in die Verbindung VCC → IN. Ohne hat bei meinem TV der andere USB-Port verrückt gespielt.

    Wird der RPi dann auch hart abgewürgt?

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

    Edited once, last by Mike72 ().

  • Also ja. Es macht ja keinen Sinn ihn einfach so weiter laufen zu lassen

    Keine gute Idee... ab und zu mal einen Hard Reset wenn sich der RPi aufhängt lässt sich ja nicht vermeiden, aber auf Dauer wird sich die SD-Karte verabschieden. Würde dir raten entweder den Vorschlag von DayOne, oder ein Read Only System einzurichten.

    Es gibt auch fertige Lösungen wie z.B. so einen Shutdown Switch.

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • So hab' ich das auch gelöst. Löte aber besser noch einen 1kOhm-Widerstand in die Verbindung VCC → IN. Ohne hat bei meinem TV der andere USB-Port verrückt gespielt.

    Wird der RPi dann auch hart abgewürgt?

    Eine vielleicht etwas blöde Frage, aber wie genau schließt man das über den USB Port eines TVs an? Ich erhalte vom USB Ausgang doch nur V+ und GND(?) Nutze ich dann V+ sowohl für das VIN am Relay als auch für das IN Stellsignal? Ich habe Relais bisher immer nur über Microcontroller über einen eigenen GPIO gesteuert.

  • MiUser078: Ganz genau so! Die 5V+ (Rot) vom USB an VIN und über einen 1k-Widerstand an IN, GND oder Minus (Schwarz) an GND. Du solltest aber vorher überprüfen, ob sich der USB-Port auch ausschaltet wenn der TV in den StandBy geht.

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • Wie versorgt ihr eigentlich den RPi? 5v vom Netzteil (das gleiche wie für die LEDs) an gpio oder lieber 5v vom Netzteil an USB? Hab gelesen, das spannungspitzen über gpio den RPi sprengen können. Oder lieber das orginale RPi Netzteil verwenden und über USB versorgen?

  • Nugsc: Ich würde den Raspberry über den microUSB befeuern, da bei jedem RPi 'ne Schutzschaltung vorgeschaltet ist, die beim einspeisen über die GPIO's übergangen wird. Wenn du nur ein Netzteil willst, kannst auch ein nicht mehr verwendetes USB-Kabel nehmen, den USB-A abschneiden und nur den microUSB verwenden. Die Kabelfarben sind rot für +5V und schwarz für GND. Grün und weiß bleiben frei. Oder sowas kaufen.

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

    Edited once, last by Mike72 ().

  • Sehr geniales Projekt. Habe selbst eine Box designed und weiß wieviel Arbeit und Filament da drin steckt :)


    Ein paar Fragen:


    - Ist dein HDMI Splitter mit Strom versorgt?

    - Ich finde nirgends den 5 poligen Stecker/Buchse. Hast Du die genaue Bezeichnung oder sogar einen Link?

    - Ich habe ebenfalls einen 65" Tb und entsprechend viel Meter werden benötigt. Hast Du auf der LED-Seite nur einmal Strom eingespeist? Oder an zwei stellen?


    An den Rest: sollte man bei der TV Größe 60 LEDs nehmen oder würden auch 30 reichen?

  • Hallo Baumtreter , danke für die Blumen ;)

    - Ist dein HDMI Splitter mit Strom versorgt?

    Jap, 5V USB. Bekommt er vom TV.

    - Ich finde nirgends den 5 poligen Stecker/Buchse. Hast Du die genaue Bezeichnung oder sogar einen Link?

    Aber klar doch :)

    https://www.reichelt.de/steckv…15i5-s-zrw-w-p181998.html

    https://www.reichelt.de/geraet…-15i5-b-rv-w-p182007.html


    Habe für das Paar incl. Versand zwar 15,30€ gezahlt. Aber dafür ist es sauber und für die entsprechende Stromstärke ausgelegt.

    - Ich habe ebenfalls einen 65" Tb und entsprechend viel Meter werden benötigt. Hast Du auf der LED-Seite nur einmal Strom eingespeist? Oder an zwei stellen?

    Ich hab an der Ecke, an der sie zusammenlaufen (quasi am Anfang und am Ende) eingespeist.

    An den Rest: sollte man bei der TV Größe 60 LEDs nehmen oder würden auch 30 reichen?

    Bin zwar nicht der "Rest" :) - aber ich würde 60 nehmen! Was spricht dagegen?


    Viele Grüße

    sorted

  • Perfekt! Danke Dir!


    Ich hab an der Ecke, an der sie zusammenlaufen (quasi am Anfang und am Ende) eingespeist.

    Bedeutet Du gehst über die Stecker mit einer Leitung raus und splittest die dann hinterm TV auf?



    Bin zwar nicht der "Rest" :) - aber ich würde 60 nehmen! Was spricht dagegen?

    Ich habe irgendwo gelesen, dass man keinen Unterschied zwischen 30 und 60 sieht ?( Aber is jetzt eh zu spät: Neues NT und Lightstrips sind auf dem weg. Hab noch ein wenig Zeit zu basteln :)



    Vielen Dank! Ich hab mir einen Wolf gesucht. Gibts dort auch die Kaltgerätebuchse? Wäre es unverschämt wenn ich auch hier nach der Bezeichnung.


    Werde mir alles zusammenstellen und langsam basteln.


    Danke Dir schon mal für die Hilfe hier :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!