Hyperion NG LEDs leuchten einfach nicht

  • Hallo,


    ich möchte nächste Woche das Projekt Ambilight in Angriff nehmen und werde, bis auf den Fernseher, dasselbe Setup haben, also Raspberry Pi 3 mit Libreelec, darauf Hyperion NG + WS2801 LEDs, auch angeschlossen an Pin 9,19 und 23.

    Heute habe ich den Raspberry Pi vorbereitet und Hyperion NG zum laufen gebracht, allerdings wird mir beim Blick auf die Weboberfläche nicht ganz klar, welche Einstellungen ich dann vornehmen muss.

    Vielleicht kannst du mir verraten, welche Einstellungen du vorgenommen hast, insbesondere unter den Menüpunkten LED Hardware und Aufnahme Hardware? Was wähle ich da alles aus? Würde mich sehr freuen, wenn du mir da weiterhelfen könntest!

  • ein.michael: Für die WS2801 einfach in LED Hardware ws2801 unter SPI auswählen. Die Aufnahme Hardware ist abhängig davon was du grabben willst. Plattform Aufnahme für interne, am Raspberry abgespielte Quellen z.B. Kodi, oder USB Aufnahme für externe Zuspieler über HDMI. Dann brauchst du noch einen HDMI2USB-Grabber bzw. Video capture card und HDMI-Splitter.

    Weitere Infos hier.

  • Mike72 Perfekt, das hilft mir schonmal weiter!

    Ich möchte eigentlich nur eine externe Quelle nutzen, einen Sat Receiver.

    HDMI Splitter und HDMI2USB-Grabber sind bereits unterwegs, beim Grabber habe ich mich für den folgenden entschieden:

    https://www.amazon.de/gp/produ…itle_o00_s00?ie=UTF8&th=1

    Muss ich dann bei Aufnahme Hardware unter USB Aufnahme irgendetwas besonderes beachten oder läuft es dann schon mit den standardmäßigen Einstellungen?

  • Gute Wahl! Der "WisFox" wird hier von vielen Usern verwendet und sollte ohne große Probleme funktionieren.

    Die Capture Cards geben standardmäßig 1920x1080 Pixel bei 60 Hz aus. Damit ist der RPi bei der LED-Berechnung aber meistens überfordert. Empfohlene Einstellungen sind max. 1280x720 Px bei 30 Hz, es reichen aber auch 720x480 und die Size Dezimation auf 6-8 runtersetzen. Die WS2801 sind aber schon recht fehleranfällig. Ich würde dir bei einem neuen Projekt die APA102 oder SK6812 RGB-NW empfehlen. Wegen dem Splitter... hast du einen Full HD oder 4K - TV?

  • Mike72 Alles klar, dann würde ich das über die Weboberfläche so anpassen.

    Lassen sich APA102 bzw. SK6812 RBG-NW auch über die Pins am Raspberry Pi anschließen oder muss ich da etwas anderes beachten?

    Beim Splitter soll es dieser werden: https://www.amazon.de/gp/produ…tle_o02_s01?ie=UTF8&psc=1

    Das Ganze soll am 4k Fernseher angebracht werden, aber in der Regel läuft da meistens nur FullHD und kein 4k, sollte dann also so hoffe ich passen.

  • Die APA102 sind genau so wie die WS2801 an die selben Pins anzuschließen, bei LED Hardware dann eben APA102 auswählen.

    Bei den SK6812 muss man ein bisschen tricksen, aber mehr dazu wenn du dich entschieden hast welche du nimmst.

    Den verlinkten Splitter habe ich auch, funktioniert auch einwandfrei bis 1080p. Wenn du CEC brauchst, den TV unbedingt an den HDMI Output 2 stecken, dann funzts. An Output 1 dann den WisFox-Grabber.

  • Mike72 Gibt es denn irgendwelche nennenswerten Unterschiede zwischen APA102 und SK6812?

    Wenn nicht, dann wäre es für mich prinzipiell sinnvoller den APA102 zu nehmen, da das Rasperry Pi Case auch schon für die entsprechenden Pins vorbereitet ist und ich nicht weiter tricksen muss.

    Danke für den Tipp mit CEC, ist ja definitiv nicht verkehrt.

  • APA102 haben RGB-LEDs, d.h. weiß wird aus rot, grün und blau erzeugt. Weiß wird daher immer leicht bläulich sein.

    SK6812 haben zusätzlich eine vierte, weiße LED und weiß ist wirklich weiß. Die APA102 sind aber auch recht gut und am Raspberry leichter zu handhaben, da sie für Daten und Clock eigene Pins haben, was die Synchronisation erleichtert.

    Die SK6812 haben nur einen Dateneingang und der RPi muss mehr berechnen.

  • Perfekt!

    Wie hast du das denn mit der Stromversorgung des Raspberrys gelöst.

    Ursprünglich hatte ich vor den Raspberry über ein separates Netzteil laufen zu lassen.

    Raspberry Pi + APA102 über ein Netzteil ist natürlich eleganter. Einfach per Micro USB Kabel anschließen und das Ende des Micro USB Kabels entsprechend an die Kabel des Netzteils löten?

  • Du kannst selbstverständlich zwei Netzteile nehmen wenn du am RPi z.B. einen Mediaplayer (Kodi) laufen hast und das Ambilight nicht dauerhaft eingeschaltet lassen willst. Du solltest dann nur nicht darauf vergessen beide GND (-) miteinander zu verbinden. Ich hab' für RPi, LEDs und HDMI-Splitter ein NT und so ein Kabel. Dazu so einen Shutdown-Switch mit dem der RPi mit meiner Harmony Elite hoch- und runtergefahren werden kann. Kommt halt immer drauf an was man will und wie groß das Budget dafür ist.;)

    Grüße aus Österreich / Greetings from Austria !

    - I don't wanna miss it anymore !

    Edited once, last by Mike72 ().

  • Das Ambilight lässt sich aber auch (per App oder Weboberfläche) ausschalten, ohne das Netzteil stromlos machen zu müssen, richtig?


    Und hast du eine Ahnung, wie sich das System verhält, wenn ich das System mit einem Netzteil über eine schaltbare Steckdose laufen lasse?

    Auf Dauer schädlich für den Raspberry oder die LEDs, wenn das System plötzlich stromlos gemacht wird oder per Steckdose hochfährt?

  • Klar, geht auch mit App per Handy, aber du kannst damit den Raspi nicht einschalten oder herunterfahren.

    Für den RPi oder die LEDs ist das Stecker ziehen wahrscheinlich weniger schädlich, kann aber irgendwann tödlich für die SD-Karte werden, wenn in dem Moment gerade ein Schreibzugriff erfolgt. Deshalb entweder einen vernünftigen Power-Switch einbauen, oder du richtest dir auf dem RPi ein Read-only System ein. Bei fertig eingerichteter Konfig die SD-Karte zu klonen kann natürlich auch nicht schaden.

  • Mike72 Konnte gerade alles einrichten und es funktioniert quasi fast so, wie ich es mir vorstelle.

    Ich habe allerdings aktuell ein Problem. Die letzte LED leuchtet dauerhaft weiß, gibt es da einen Trick, damit die LED ebenfalls angesteuert wird? Habe mehrfach die LED Konfiguration überprüft und die Anzahl der LEDs angepasst, allerdings konnte ich das Problem nicht lösen.

    Hast du eine Idee?

  • Wenn deine LED Konfiguration stimmt sollten auch alle LEDs korrekt angesteuert werden.

    Einspeisepunkt, Anzahl LEDs insgesamt, links, rechts, oben und unten stimmen?

    Nicht vergessen, LED 1 = 0, LED 2 = 1, LED 3 = 2 usw. D.h. du solltest immer eine LED weniger haben als in der Konfig.

    Könnte aber auch sein, dass gerade die letzte LED oder der IC defekt ist, dann einfach abschneiden und ersetzen.

  • Servus!


    Vielleicht kann mir hier jemand helfen. Habe einen Pi 4 mit Libreelec + Hyperion.ng und einen ESP8266 + Wled.

    Soweit funktioniert eigentlich alles. Aber bei einem Neustart vom RPi bekomme ich keine Verbindung zum Wled. Erst wenn ich denn Schalter LED-Hardware einmal EIN, dann AUS und wieder EIN schalte.

    Ich möchte halt, dass sich die Verbindung selbstständig wieder aufbaut.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!