Only first led of WS2818B lights up

  • I have the issue as described above.

    Config: Rpi3, Hyperbian, WS2812B 240 leds, connected to GPIO (18), powerblock powersupply (100W)

    When I start up Hyperion, only the first led powers on.

    Capture card works and that first led responds to what the capture card 'sees'

    All leds were on once, after that I rebooted the Rpi to test again, and the problem was back.

    I can't find out the problem, checked all connections over and over.

    I measure almost 5V at the end of the tape, so power is good and tape is not cut somewhere.

    I added the config in the attachments, it must be in there....

    I hope you can help me...

  • what color is the LED? I'm not sure if it has bearing, but i had the problem initially. also, what input resolution are you currently testing on?

    When I ran 4k, i had no signal. When I ran 720 or 1080 it ran immediately. Also... I forgot to add... my PC was set to 120hz @ 4k, and that was an issue. The splitter I had initially was HDCP 2.0, and everything else was 2.2.

    Problem is I fixed everything almost all at once. I know for a fact the 4k@120 held me up after I switched the splitter out

  • I had the same problem, i use the gpio pins for data. So i ran the following 2 codes in this order

    sudo systemctl disable --now hyperiod@pi

    sudo systemctl enable --now hyperiond@root

    then reboot.

    It worked for me, but im new aswell and my lights dont work correctly either...

    Maybe someone can ferivy what is just typed...

  • Thanks Yasir, this looks like transfering Hyperion from one user to another.
    I read something about no rights to use the GPIO.
    I will give it a try :)

  • You need to run hyperion as root with this configuration (device 'ws281x) PWM

    sudo nano /etc/systemd/system/hyperiond@.service

    Remove the User sessionline and save with CTRL+O and exit CTRL+x.

    Don't forget to reboot

  • Thank you Lighting-guy.

    A few remarks. I don't have 'hyperiond@.service', I do have hyperion.service.

    The content of that file does not have a User section.

    See below the content of the file above.


    Description=Hyperion ambient light systemd service









    The changes of Yasir also don't work because of the system service name.

    Edited once, last by Axel1972 ().

  • By the way, I would expect it to be a more config issue...
    As the first led does everything you would expect, just led 2 until 240 don't :(

    So addressing the other 239 leds seems to be the issue, rather then rights to use the GPIO (IMHO)

  • Oké. But I searched of the file, it does not exist on my Pi with Hyperbian.

    Can anyone confirm my config (screenshots) Is good?

    Any other way to test the connection to the led tape?

  • Is there anything in /boot/config.txt that might be causing issues?

    Here is the listing:

    # Uncomment this to enable infrared communication.



    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)



    # Enable DRM VC4 V3D driver on top of the dispmanx display stack





  • if all of this dont work then we do something diffrent

    in terminal of raspi;

    sudo systemctl disable --now hyperiond@pi

    sudo systemctl enable --now hyperiond@root

    sudo reboot now

    copy and paste this code line with ctrl/shift +V in terminal then press enter

    until last line of reboot

    after reboot

    sudo apt-get update

    sudo apt-get upgrade

    then open hyperion and post debug log

  • On the first command (like earlier) Failed to disable unit: Unit file hyperiond@pi.service does not exist.

    I will run the update/upgrade, did that after install, but who knows :)

  • I think the 2nd LED is defect. You can test this, if you have male jumper cables. You said, measured 5V and GND at the end?

    That's good. Make a connection after the first LED (Data Out) to the third LED (Data In). :thumbup:

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • Hi Mike,

    I think you are right! I already tried holding the data out to the middle wire, but that did not give the right result.

    Now I waited a few exta seconds and you could see the software addressing them all.

    So, I cut the first few leds from the tape (I already did the same on the other side, seems damaged as well.

    Tomorrow I will do some soldering of wires. Any suggestions how? I mean, what is the most stable approach?

    I have a slodering station, heat shrink tube etc.

  • :thumbup: I also had a few strips with defective LEDs. The simplest solution is to cut out the defective LED and solder in a new LED using short pieces of wire. The copper areas should be large enough. Even easier if the strip is not yet stuck to the TV.

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!