WLED Instanz kann nicht mit Fritzbox verbinden

  • Hallo,
    ich hoffe es ist ok, wenn ich eine Frage zu WLED/Fritzbox stelle:
    ich habe mehrere WLED Instanzen laufen, diese funktionieren alles bestens - nun wollte ich eine weitere hinzufügen: einen Wemos D1. Ist soweit alles richtig konfiguriert und lässt sich über den Hotspot WLED-AP und Handy ansteuern.
    Das Problem: trotz richtiger Wifi-Logindaten kann sich der Controller nicht bei meiner Fritzbox anmelden - dieser erscheint unter "Erfolglose Anmeldeversuche" mit der Mac-Adresse. Habe den Wemos D1 schon mehrmals geflasht, auch mit unterschiedlichen WLED-Versionen - 5ghz deaktiviert, WLAN Kanal auf 1/11 gestellt .. leider ohne Erfolg.

    Es scheint also an der Fritzbox zuliegen. Hat jemand eine Idee woran es liegen könnte?

    PS: der Controller erscheint am Handy immer noch als WLAN-Hotspot am Handy - eigentlich sollte er das nach Eingabe der Wlan-Zugangsdaten nicht mehr(?) Außerdem wird er mit einem Schloß im Icon dargestellt, also passwortgeschützt, sollte eigentlich standardmäßig auch ohne sein ..

    Always ready for betatesting + sharing ideas about WLED / Hyperion / Maker stuff :)

    Edited 3 times, last by fuxi ().

  • Bist sicher, dass bei Dir für DHCP freigegebener IP Bereich auf FritzBox nicht (zu stark) eingeschränkt ist, also dass es genug freie IPs gibt? Nur als Idee... Falls keine Eisnchränkung eingestellt, versuch umgekehrt die oberen IPs ab so 200 auszuschliessen (habe da über Probleme gelesen in Verbindung mit ESP). Nur als Idee.. keine Ahnung was Du genau ein Problem hast.

  • Versuch' mal allen deinen Devices fixe IP-Adressen zuzuweisen. Ich hab' zwar keine FritzBox, glaube aber mal gelesen zu haben das da nur irgendwo ein Häkchen zu setzen ist.

  • Du kannst das auch in den WLED Einstellungen machen:

    WiFi setup

    Static IP (leave at 0.0.0.0 for DHCP):

    LG OLED65CX9LA

    RPi4 mit Libreelec und Hyperion-ng

    Splitter: FeinTech VSP01222 Grabber: DIGITNOW!

    Denon AVR-X3300W - Lautsprecher Gauder Akustik Arcona 100. DM920 Firestick 4k HTPC: Asus PN61 Samsung Blueray Player


    Schaltnetzteil 5V 20A/ Wemos D1 mini - WLED -mit SK6812 RGBW-NW 60 LEDs/m.

    Insgesamt 755 LEDs um den TV / oberhalb, hinter den Lautsprechern links und rechts und in einer umgebauten IKEA Lampe.

  • Hallo,

    ja alles schon kontrolliert, die Instanzen sind bereits alle mit fester IP in der Fritzbox definiert.

    Achja - alle anderen Instanzen verbinden problemlos, nur diese eine neue nicht, als hätte es was mit der Mac-Adresse zu tun.

    Habe schon Factory-Reset gemacht bei der Fritzbox, hat nichts gebracht ..

    Hab dann testweise einen baugleichen anderen D1 geflasht, der konnte auch nicht verbinden.

    Hab dann noch einen ESP32 geflasht, der konnte sich direkt problemlos verbinden .. alles sehr seltsam.

  • Moin, kann auch sein das wenn man im einen Mehrfamilienhaus wohnt und mehrere Parteien eine Fritz haben,dann versuchen mehrere Fritzen auf den Controller Zugriff zu nehmen. Daher ist es besser nicht mehr Fritz Box zu heißen und auch Unterschiedliche Benennung der Funknetze auf 2,4 und 5 GHz zu deaktivieren. P.S war bei mir der Fall ,und wladi hat mich auf der Idee gebracht.

  • Die fritzbox "nimmt" gar keinen Zugriff auf den Controller, sondern wenn dann umgekehrt. Allerdings sollte es mit einer fremden fritzbox gar keine Verbindung geben, weil Passwort falsch. Wenn wirklich eine fritz.box im Haus den gleichen WLAN Namen (SSID) verwendet hast du natürlich evtl. ein Problem, du weißt nicht mit welcher du gerade versuchst dich zu verbinden (außer vielleicht über die Signalstärke, aber auch nicht in jeder Situation) - das sollte man unbedingt vermeiden, insofern ein guter Tipp!.


    Die unterschiedliche Bennenung der Freuenzen sollte im Grunde kein Problem machen, aber sie hat auch wenig Sinn, bei mir heißen sie auch gleich.

  • Also hier nach bin ich gegangen, und seit dem läuft es.


    Namen des WLAN-Funknetzes (SSID) anpassen

    1. Klicken Sie in der Benutzeroberfläche der FRITZ!Box auf "WLAN".
    2. Klicken Sie im Menü "WLAN" auf "Funknetz".
    3. Deaktivieren Sie die Option "Unterschiedliche Benennung der Funknetze auf 2,4 und 5 GHz", um für beide Funknetze denselben Namen (SSID) zu verwenden. Nur so kann die FRITZ!Box Ihre WLAN-Geräte automatisch in das jeweils optimale Frequenzband steuern ("Band Steering").
    4. Aktivieren Sie die Option "Name des WLAN-Funknetzes sichtbar". Dadurch verhindern Sie, dass einige WLAN-Geräte keine Verbindung zur FRITZ!Box herstellen können und ermöglichen es der FRITZ!Box, Ihre WLAN-Geräte im Mesh optimal zu steuern ("WLAN Mesh Steering").
    5. Tragen Sie im Eingabefeld "Name des WLAN-Funknetzes (SSID)" einen individuellen Namen ein. Dadurch verhindern Sie, dass Ihre WLAN-Geräte versuchen, sich bei gleichlautenden WLAN-Funknetzen in der Umgebung, mit dem falschen WLAN-Router zu verbinden.
    6. Klicken Sie zum Speichern der Einstellungen auf "Übernehmen". Bei der Übernahme des neuen Funknetznamens werden alle WLAN-Verbindungen zur FRITZ!Box getrennt. Die WLAN-Verbindungen zur FRITZ!Box müssen anschließend neu eingerichtet werden.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!