Ws2815 + raspberry

  • Hello everyone, I state that I am new in the field and I tried to search the forum before opening this post. I have a problem with my configuration.

    I installed the latest version of hyperion on my rasp model B + (version 2017) and connected my WS2815 (12v) led strip to the GPIOs, to be precise, the DI of the strip connected to the MOSI GPIO, the BCK to the GPIO SCLK and GND in common with the 12v power supply. All this through a level shifter to amplify the data from 3.3v to 5v. I tried to carry out some tests by setting the HARDWARE LEDs with the ws2812spi controller and it worked perfectly, but here my problems started. I plugged in the grabber, splitter and everything else but the LEDs didn't light up anymore. I again made some tests by connecting only the strip to the raspberry without any success. I checked the current, voltage, continuity and everything on the hardware level would seem ok. Can anyone tell me where am I wrong? How come now all of a sudden they don't work anymore? I am attaching photos of the hardware configuration. Thanks a lot in advance to those who will answer.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!