Anyone having success with WS2815?

  • Hi folks,


    So I've got a ws2815 strip with 300 LEDs, and can't get it to work with GPIO 18 on RPi 3B+. I've tried it both with and without level-shifter. Not only Hyperion doesn't make the strip light up, but also other software like Adafruit Neopixel library. Best I could get via Neopixel is either all-white or random colors. I tried various settings (freq 400 and 800 kHz, DMA channel 5 and 10). It feels like the problem is on software side, but I don't know what else to try, as others have reported this chip working with rpi281x library just fine.


    At the same time, the strip works perfectly fine with the stock SP107E controller. So at least I know it's alive. I've also measured the output levels on the Pi, and level-shifting seems to work correctly.


    Thanks a lot for any help!

  • Alright, solved it!! Turns out indeed, it was a software problem as I had to disable the Audio driver, which conflicted with PWM signal (hence producing wrong colors etc.). All explained here: https://github.com/jgarff/rpi_ws281x#pwm and here (unfortunately, I can no longer find this page for the new Hyperion..) https://web.archive.org/web/20…oject.org/wiki/3-Wire-PWM


  • PWM

    Since this library and the onboard Raspberry Pi audio both use the PWM, they cannot be used together. You will need to blacklist the Broadcom audio kernel module by creating a file /etc/modprobe.d/snd-blacklist.conf with

    Code
    blacklist snd_bcm2835

    If the audio device is still loading after blacklisting, you may also need to comment it out in the /etc/modules file.

    On headless systems you may also need to force audio through hdmi Edit config.txt and add:

    Code
    hdmi_force_hotplug=1
    hdmi_force_edid_audio=1

    A reboot is required for this change to take effect

    Some distributions use audio by default, even if nothing is being played. If audio is needed, you can use a USB audio device instead.



    don't forget to add ( can not hurt) or above doesn't work for you to put a line extra in config.txt


    dtparam=audio=off

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!