2nd set of ws2812B LEDs. Still cant get ANYTHING to light.

  • Hi All,

    I'm attempting a Hyperion setup. The Phillips plasma TV with Ambilight we bought in 2007 finally went out. So, when we shopped for a replacement, I told my wife I wanted to add a DIY Ambilight. I'm no expert with the Pi. But, I previously had Kodi and MAME/Game system emulation on a Pi2. I am quite comfortable with building electronics projects.

    I'm on my second set of ws2812B LEDs for this project. I can't get either set to work.

    I bought the second set thinking I got a bad one the first time around. I'll likely try using the first set at a later date on the virtual pinball table I built. (Too many projects - hence my username)

    Screen capture appears to be works. I can see it in the Hyperion GUI when accessing through the Wifi xxx:8090 port.

    I have a 5v/10A running both Pi3 and LEDs. But, I've tried powering Pi separately as well.

    I've added a 25v/1000uf cap at the barrel Jack connector. This was mentioned in a YT video I watched. I figured that it couldn't hurt. I have NOT tried the optional 470 ohm resistor or Logic Level board on the data line (yet). LED Data connected to GPIO18. Barrel Jack negative is linked to GND (Pi pin6).

    No errors or warnings shown in log file.

    Suggestions please?

  • Hey DIY, for anyone to answer this properly, we need more information



    how setting up, what gpio pins are you using etc.

    But a shot in the dark, you are using hyperbian alpha 10 on a pi with your LED on ws281X. If so there is a work around to this. Also a rookie error is not grounding your pi gpio and leds together (LED won't work without it)

  • Yes, I'm using a Pi3 running HyperBian v2_alpha10


    My 5v/15A PSU (not 10A, as I think I typed last night) is powering ws2812B LED strip and Pi using a barrel jack (haven't run power to far end of the LED strip yet). Yes, using GPIO18 for data and GROUND is shared to pin 6 on GPIO header of Pi. Hyperion Web UI is set to ws281x as well.

    Could you share the "work around"?

  • This is easiest if you know how to add the commands in putty via PC, or directly on pi

  • Yes, I'm using a Pi3 running HyperBian v2_alpha10

    No errors or warnings shown in log file.

    Suggestions please?


    do you see or don't you see the startup effect on the leds?

    because if Hyperion is booting up NEVERTHELESS the Hyperion service is running under root, you should always see the startup effect.

    mostly the rainbow colours.

    so if you are seeing nothing then something else is the matter within your setup

    where's your log out of debug section after reboot? >> if there's no warnings like you said then has to be a hardware problem.

    can be numberous of things.

    • first look at datadirection of your ledstrip, arrow has to go away from GPIO
    • power PSU > not more than 5 volts DC under load, has to be a clean steady DC!
    • power the ledstrip ( if possible) from both sides with +5 volts and GND ( yes you can do that, no you will not shorten)
    • did you correctly saved your LED layout? hence; look at led numbers in the file if they are there
    • common GND > connect everything from GND together to GND / V- /minus to PSU, it doesn't matter if you are powering the PI separately but common GND is important
    • use more than one pin on the PI for GND, at least two of them
    • don't use barrel connectors but solder instead would be me advice.
    • check the AWG / thickness of wires, to thin is causing powerdrop because to much resistance on the wires.

    after you did all of this, check if Hyperion runs under root .


  • I get no startup effect. Yes, set for rainbow I believe.

    I'll post my log this evening. It didn't report any errors, so I didn't add in my OP.

  • This is easiest if you know how to add the commands in putty via PC, or directly on pi

    I'll try that this evening. I seen this post last night when I submitted my OP.

    BUT...I believe this post mentions some lights working. So, I considered mine to be a different issue.

  • I didn't get a chance to work on it last night. This evening, I hooked up a monitor to my Pi3. I get an occasional "undervoltage" warning. Checking PSU, it's steady at 5v. I tried the "Hyperion Free" colorwheel app and get lights! But, the colors are reversed from what wheel shows. Still no luck with Ambilight setup. I will try the suggested work around. But, I'm confused why one would work and the other does not.

  • In top right hand corner of UI is a drop down colour wizard, it will assist you in setting red green and blue correctly.

    After setting, if you want to try setting your colours to match more accurately use this video, pause on each colour and play around with the gamma settings (if you set all gamma to 1.0 first, that's neutral) Raising the value decreases the colour strength and vice versa.

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • But, the colors are reversed from what wheel shows

    switch around RGB byte order to GRB or GBR or whatever :thumbup:

  • This evening, I hooked up a monitor to my Pi3. I get an occasional "undervoltage" warning

    yes that's kind of normal with the PI3b, i have a beast of PSU but still that warning :)

    I think the reason is that normally the PI is connected to a smart charger on USB port, these types of chargers have a higher voltage than 5 volts to charge" the device with, the moment the current is being drawn by the PI the voltage drops somewhat but still higher than 5 volts.

    Because you have a ledstrip connected to the same PSU it can't be higher than 5 volts, but PI is most happy to run at 5.3 volts

    so there's your undervoltage warning :)

    but you can get rid of that by put a line in config.txt 



    Btw the lightning icon can't hurt your PI if it runs on 5 volts.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!