Hyperion with Apple TV 4K flickering black screen/static noise

  • Hey everyone!


    I've recently finished my Hyperion setup and I encountered a problem I can't find a thread about..

    my Apple TV 4K doesn't want to show a picture, it keeps flickering between black screen and static tv noise. When I check the live video on the web configuration I get somewhat of a picture with a purple tint, but same thing there, it just flickers between black screen, static tv noise and for a millisecond showing the ATV home screen with a purple tint.


    I tried it with a Apple TV 4 (1080p) and it works perfectly. I'm suspecting that it's the capture card I bought, but I also tried with a HD60S I had laying around and I got the same problem. The capture card I bought is this one: https://www.amazon.se/gp/produ…tle_o01_s00?ie=UTF8&psc=1


    The rest of the hardware is

    RPi3

    W2812B 60led/m

    5v 8A power supply


    All this is used on a Sony 46" tv, about 196 leds in total.


    Is it possibly the HDCP2.2 that's messing up? what could I do to bypass this and be able to use the ATV4K instead of the regular ATV4?


    EDIT: Running on Hyperion alpha9.



    Thanks!

  • i saw this i believe, you have to update the firmware/drivers of the OS.



    let me find something that i posted before.


    first update your OS


    sudo apt-get update

    sudo ap-get upgrade



  • Lightning-guy77


    I tried to update the OS, the problem still persists.

    This is how the live video looks like: https://gyazo.com/93074566eef8696801c55f69a44e0f86


    I tried disabling the LED hardware instance, so no LED lights are on and the tv is still flickering between black screen and static noise.. I'm feeling more and more inclined about it being the capture card not working with HDCP2.2 (if thats what ATV4K uses..)

  • I tried to update the OS, the problem still persists.


    and the other link i gave you ?

    update the firmware and library's


    its possible its a problem with HDCP

  • I had tried activating the settings in the Apple TV 4K to match the dynamic range and frame rate and it didn't work. I thought let's try that again after the OS update and it seems to be working now.


    I get the rainbow bar for a second or two when playing Netflix or Disney+, but after that it runs smoothly until I stop playing (clicking the menu button on the Siri remote) and I get the rainbow bars for a second or two again.


    But all in all, it looks like it's working now, I'm still suspicious about the capture card and it's compatibility, but for now as it's working, I'll go ahead and use it and eventually upgrade to a better hdcp2.2 compatible card instead.


    Thanks for the help & advices Lightning-guy77 & james2brite!


    /M

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!