Can't address more than 255 leds

  • Hi everyone

    I'm using the Pi3 with a 5m + 2 x 1m strips of SK6812 RGBW total of 420 leds, I can't address more than 255 leds.

    From the other threads it looks like I need to set my max_led, but I don't know where or how.

    I need to run a 7m strip for my 100" projector screen.

    any help would be greatly appreciated.

    • Best Answer


    you probably reached maximum of packets SPI can send,

    you need to ad spidev.bufsiz=1024000 to cmdline.txt,


    dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=5728b712-02 rootfstype=ext4 elevator=deadline rootwait loglevel=3 consoleblank=0 plymouth.enable=0 spidev.bufsiz=1024000 

    cmdline.txt is a file on the SD card, boot section > spacebar is needed at last line like example otherwise Raspi can not boot anymore

    it have to be at the end of the line, then reboot

    then check in terminal (SSH) if size has altered, and copy paste the big text..

    pi@Hyperbian:~ $ cat /sys/module/spidev/parameters/bufsiz

    result have to be 1024000 in next line after reboot

    this should activate the SPI controller fully

    Ledsetting is at Hyperion localIP:8090 example ( 8090 is standard port)

    Led hardware/ led layout

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!