WS2815 + RPi3 all LED stay bright white

  • Hi everyone.

    I recently decided to start my first project with raspberry Pi and wanted to set up an ambilight system for my projector screen.


    I have got mi RPi3 with hyperbian, WS2815 strip with common ground to the RPi3, and data wire into GPIO 18.

    NONE of the LED turn on, not even from the android app.


    However, when I tried changing from GPIO 18 to GPIO 10, I got the strip to light up, but only in bright white. When trying to change the color from the android app, the color (or the effect) changes for one second, and then turns back to bright white.


    I tried running hyperion as root insitead of pi (I'm a beginner user so I'm not 100% sure I'm doing this the right way), and this didn't solve my problem.


    I also tried putting the audio kernel module in the blacklist as stated here : https://github.com/jgarff/rpi_ws281x#pwm

    But got no luck at all.


    Could it be that I need a logic level converter?


    Please help me I'm desperate, and sorry for my extreme ingorance, this is my first raspberry project.


    Thanks everyone!

  • the mainvoltage that this strip needs to run at is 12 volts DC, but the signalvoltage requires to be 5 volts from the GPIO to the ledstrip. \


    standard the Raspi GPIO can not generate more than 3.3 volts maximum so yes change is big that you need a logic level converter to boost the signal up to 5 volts and then it will work..


    first my advice is to leave the PWM alone and try to run this strip on SPI controller, SPI dev baudrate default.

    you need GPIO 10

    GPIO 10 = data, connect to DI

    BI connect to GND


    make sure inverted signal options out at led settings and SPI is on.


    dtparam=spi=on

  • Sorry but, where should I put the "dtparam=spi=on" command? I'm very new to this

    normally its allready activated when you are deployed the Hyperbian image distro


    but if you want to find it, its in config.txt boot area on SD card

  • Update:

    I formatted and installed Hyper HDR from terminal, and got the same results:

    the color/effect works, but only for one second, then the strip becomes white.

    Also, tried again with GPIO18 and nothing worked. Trying with GPIO10 it works as above.

    Ordered a logic level shifter, let's hope and see.


    (I tried with 2812spi as you said, but didn't work, maybe I'm missing something...)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!