Hyperion.ng Alpha 10 Grabber stürzt ständig ab

  • Hallo, seit dem update auf Alpha 10 stürzt ständig der USB Grabber bei mir ab. Dieser liefert dann anscheinend kein Bild mehr. So ist die Vorschau schwarz und die LEDs leuchten nicht ein Hyperion restart behebt das Problem bis zu einem neuen Abbruch.


    Anbei befindet sich mein Log (Protokoll)


    Verwendet wird eine virtuelle Debian Maschine auf einem Intel Nuc. Dort ist ein USB Grabber angeschlossen. Installiert habe ich Hyperion mithilfe der offiziellen Installationsanleitung. Habe 3 Instanzen mit WLED aktiv.


    Log 1

    https://pastebin.com/KmXkGWHB


    Log 2

    https://pastebin.com/N0i1rqdn


    v4l2-ctl --all




    Danke

  • Was ist das Hostsystem der VM? Und wie reichst du den Grabber an die VM weiter?

    Samsung 3D UHD 55"

    VU+ Uno 4k SE FBC Twin DVB-S2

    Samsung HT-J7500W 5.1

    Rasp Pi 4 B 4GB - 64GB USB 3.1 Boot (Home Assistant OS + Hyperion NG Addon latest)

    SK6812 IP65 60LEDs/m - AZD ESP8266 - WLED

    FeinTech VMS04201

    Capture Card HDMI/USB

  • Ich benutze ein Intel Nuc, woran der Grabber per USB angeschlossen ist. Dort läuft in Proxmox eine Virtuelle Maschine mit Debian.


    In Proxmox hab ich den Grabber zur VM weitergeleitet

  • Du könntest mal testen, ob die Weiterleitung in die VM vllt das Problem auslöst. Manche USB Redirectors sind nicht besonders sauber programmiert. Daher schmieren die Dienste gerne mal ab. Leider bin ich mit der Umgebung selbst nicht vertraut, ich kenne aber einige andere virtuelle Umgebungen und da kann dies schonmal der Grund sein.
    Weiteres, was ich gestern rausgefunden habe, solltest du einen Grabber nutzen, der in Hyperion mit YUVY läuft, dann musst du den an einen USB3 Anschluss anschließen, da YUVY ggü. mjpeg einen erhöhten Datenstrom hat. Läuft solch ein Grabber an einem USB2 Anschluss, kann das zu Abstürzen führen.

    Samsung 3D UHD 55"

    VU+ Uno 4k SE FBC Twin DVB-S2

    Samsung HT-J7500W 5.1

    Rasp Pi 4 B 4GB - 64GB USB 3.1 Boot (Home Assistant OS + Hyperion NG Addon latest)

    SK6812 IP65 60LEDs/m - AZD ESP8266 - WLED

    FeinTech VMS04201

    Capture Card HDMI/USB

  • Danke für deinen Tipp! Ich habe Ubuntu nochmal neu installiert. Leider wieder das gleiche Problem. Stürzt innerhalb paar Sekunden immer wieder an. Benutze Proxmox 7.0-11 und Ubuntu 18.04.3. Leider kenne ich mich hierzu auch nicht gut aus. Wenn ein Experte hierzu noch einen Tipp hat wäre ich sehr dankbar!


    Der Grabber läuft über USB3 und wird in der VM über den Punkt Hardware mit USB 3.0 durchgeschleift.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!