Hyperion NG Alpha10 Grabber Problem

  • HDMI Handshake Problem.

    Welchen Splitter verwendest du?


    Kann verschiedene Ursachen haben.

    Falsche Einschaltreihenfolge.

    Splitter hat keine 5V für den Handshake.

    HDMI Kabel.


    Quote from ThoRiWa

    Wenn ich alles einschalte bekomme ich kein Signal zum TV vom HDMI Splitter.

    Kommt am Grabber etwas an?


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Bisher hatte ich immer diesen. War nie ein Problem.

    Ich benutze den auch an meinem ersten System im Wohnzimmer.


    An dem neuen System war es auch hin und wieder was aber nicht so sehr gestört hat.

    Ich meine seit ich den Digitalen Grabber dran habe eher schlecht bis gar nicht.


    Ich muss dann immer die 2 Ausgänge abstecken dann gehts wieder.

  • Quote from heimkino-praxis.de

    Ausgeführt wird der HDMI-Handshake immer dann, wenn ein Gerät in einer HDMI-Kette eingeschaltet wird. Weiterhin können das Umschalten einer Signalquelle, die Änderung des ausgegebenen Signals oder Einstellungen an einem der Geräte einen Handshake zur Folge haben.

    Umschalten einer Signalquelle könnte das Problem auch beheben.

    Ein Splitter der die EDID Daten vom TV durchreicht und speichert könnte das Problem auch lösen.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Nein , der TV und der USB Grabber benötigen ja beide Bild und für den Grabber muss es evtl. noch 1080p skaliert werden.


    Wenn du nur eine Quelle hast hilft es nicht den Telekom Receiver aus/einzuschalten?


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Das aus und einschalten der Externen Quelle, der Receiver brachte nicht den gewünschten Erfolg.


    HDMI Kabel tausch war ebenso erfolglos.

    Habe jetzt OUT 1 und 2 am Splitter getauscht, was ich schon öfter getestet habe, und nun scheint es im Augenblick zu funktionieren.


    Lasse es mal so.

    Wled läuft auch wenn alles eingeschaltet wird. So soll es ja auch sein.


    Danke erst einmal an pclin  Paulchen-Panther


    Grüße

    Thomas

  • Hi pclin


    hätte da noch eine Frage zu dem systemd-hyperiond@root.timer


    Wo genau kommt der hinein?

    Es scheint doch nicht so richtig zu funktionieren mit der LED-Hardware. Ich musste sie wieder einschalten... :/

    Jetzt wollte ich noch den Timer mit rein machen aber wohin?


    eventuell habe ich falsch platziert?


    ...etc/systemd/

    oder

    ...storage/hyperion/service...



  • Kann z.B. nach /etc/systemd/system.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Wenn es denn Ordner bei dir nicht gibt kannst du testen ob es in /etc/systemd funktioniert.

    Reinkopieren und systemctl daemon-reload eingeben.

    Dann mit systemctl status 'deine servicename'  testen ob der service da ist.

    Dann den service enablen, systemctl enable 'deine servicename'

    Und denn hyperiond service disablen, systemctl disable hyperiond@'deinUsername'.

    Ausgaben lesen und prüfen.

    Wenn dort keine Fehler ausgegeben werden und timer und service namen korrespondieren und der Aufruf im timer service richtig (root oder pi) ist

    Code
    hyperiond@root.service
    systemd-hyperiond@root.timer

    sollte beim nächsten reboot hyperion 1min nach systemstart leuchten.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Hi pclin,


    so, WLED läuft wieder. Wemos war defekt.


    Also der Timer schein. nicht zu funktionieren.

    Die LED Hardware muss eingeschaltet werden nach dem starten des Pis


    Hier mal die Ausgabe .... Kann leider nichts damit anfangen.

    Wenn ich in Hyperion die LED Hardware einschalte gehts dann.

    Also es geht der Timer nicht.


  • Ich kann leider nicht genau sagen was da bei dir schief läuft.


    Mit After=network-online.target sollte das aber funktionieren, den .timer benötigt man dann eigentlich nicht.

    Hast du das mit dem neuen Wemos getestet?


    Wenn es nicht geht mit systemctl status hyperion.service prüfen und die Ausgabe posten.


    gruß pclin


    Bei dir müsste es auch

    Code
    hyperion.service
    systemd-hyperion.timer

    sein, und mit systemctl status systemd-hyperion.timer kannst du auch prüfen was da evtl. schief läuft.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin: Ein Beitrag von pclin mit diesem Beitrag zusammengefügt. ().

  • Hallo zusammen,


    seit einer gewissen Zeit habe ich passiv in diesem Forum die eine oder andere Information bezogen.

    Insbesondere pclin habe ich als sehr geduldig und kompetent erlebt. Respekt, pclin!


    Hier meine Config (hyperion.ng alpha 10), mit welcher ich recht zufrieden bin und welche ein relativ gutes Ergebnis liefert.


    RPi 4 4GB

    Hyperbian (hyperion.ng 2.0.0-alpha.10)

    LED-Stripe SK6812 RGBNW 5m (265 LEDs im Einsatz)

    HDMI Splitter FeinTech VSP01222

    HDMI Grabber WisFox

    WLED Microcontroller D1 Mini NodeMcu mit ESP8266


    Zuspieler: AppleTV 64GB

    Smart-TV: SONY KD-65XH9005


    CEC funktioniert gut, so dass AppleTV sich mit der Fernbedienung des Fernsehers steuern lässt.

    ARC habe ich noch nicht testen können.

    Hier ein kurzes Test-Video auf youtube.


    youtube Video

  • Hi pclin ,


    mit dem Neuen Wemos hatte ich das noch nicht getestet da das ganze Verhalten das identische ist das ich die LED Hardware einschalten muss.


    Werde das noch einmal versuchen zu analysieren und berichten.

    Ich habe auch immer noch das Problem mit dem HDMI Handshake das ich kein Bild auf dem Tv habe. Nicht immer aber nervig.


    Anderer Splitter vielleicht? HDMI Splitter FeinTech VSP01222?


    Also ich werde berichten.


    Danke Dir aber bis hierhin pclin


    Schöne Grüße


    Hier die Ausgabe von


    Code
    After=network-online.target


  • Die Ausgabe von systemctl status hyperion.service bitte posten wenn es nicht funktioniert/startet.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • Wenn es am Timing liegt, also hyperion schon gestartet ist wenn das Netzwerk noch nicht Online ist wird es eine Meldung bei systemctl status hyperion.service geben die in etwa so aussieht

    Code
    Sep 19 23:33:13 dreamtwo hyperiond[565]: 2021-09-19T23:33:13.107 hyperiond LEDDEVICE    : <WARNING> (192.168.178.82:19446) Write Error: (7) Unable to send a message
    Sep 19 23:33:13 dreamtwo H[565]: (192.168.178.82:19446) Write Error: (7) Unable to send a message
    Sep 19 23:33:16 dreamtwo hyperiond[565]: 2021-09-19T23:33:16.804 hyperiond LEDDEVICE    : <ERROR> Device disabled, device 'wled' signals error: 'Failed resolving IP-address for [WLED-unten-33], (2) Temporary failure in name resolution'
    Sep 19 23:33:16 dreamtwo H[565]: Device disabled, device 'wled' signals error: 'Failed resolving IP-address for [WLED-unten-33], (2) Temporary failure in name resolution'
    Sep 19 23:33:18 dreamtwo hyperiond[565]: 2021-09-19T23:33:18.856 hyperiond LEDDEVICE    : <WARNING> Previous line repeats 200 times

    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng alpha.10 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Hi pclin


    also bei mir sieht das so aus. LED Hardware ist nicht an in Hyperion.



    Quote

    Mit "After=network-online.target" sollte das aber funktionieren, den .timer benötigt man dann eigentlich nicht.

    Damit alleine geht es nicht.

    den Timer habe ich rausgenommen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!