HyperBian not working after upgrade to alpha 10

  • Hey all,


    WS2812 on GPIO 18 Pi 3

    Checking on my V9 instance of HyperBian, seen an upgrade mentioned. Sadly no way to upgrade though the UI so decided to start again (with screenshots taken of the settings) with the new version V10 (after a promises of easier usability in the release notes)


    Now my lights don't work at all. All settings the same, and nothing. Do have this in the logs;


    Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: mmap() failed'


    Looking around and seeing something about running in root? Very confused about this, Im using the HyperBian image (2021-07-18-HyperBian-lite) I guess the latest.


    If you're going to release an image that can be directly flashed with SSH not enabled (with the "user friendly setup" connotation that implies), why would you not have all this configured to run correctly?


    Looking a bit more there is a pull request for a script to be added to HyperBian.

    I just have no idea why;


    A) the download is still up or, maybe more importantly.


    B) this info is not front and center on the HyperBian project page.


    How are casual users meant to understand what the hell is going on if the devs are not sharing the info


    Now to pull everything apart again and downgrade to v9

    Apologies for this being a little rant-y, but common guys, give me the rights, ill update the bloody page.


    Oh FFS, I cant even downgrade be cause the only have the latest release :(


    Update your doco, it only takes a min to do and saves a lot of frustration for people using your product.

  • Now my lights don't work at all. All settings the same, and nothing. Do have this in the logs;


    Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: mmap() failed'



    standard this function needs Hyperion.NG to run as root, developers can not implement this in the Hyperbian 2.10 Alpha build.

    don't ask me why, it has to do with coding.



    explanation, if used PWM ws281x ledcontroller than you have to run Hyperion under root

    this is because audio services are being used by the PI and it has priority,

    if changed to run Hyperion under root then Hyperion gets priority over the GPIO and thus audio services.

    PWM is some kind of audio pulse..



    ad a line in config.txt dtparam=audio=off


    in terminal:

    pi@HyperBian:~ $ sudo systemctl disable --now hyperion(d)@pi

    pi@HyperBian:~ $ sudo systemctl enable --now hyperion(d)@root

    (d) try the code with and without the d, no hooks used



    or in terminal


    sudo nano /etc/systemd/system/hyperiond@.service



    Remove the User sessionline User=pi and save with CTRL+O and exit CTRL+x.


    Don't forget to reboot


    How are casual users meant to understand what the hell is going on if the devs are not sharing the info

    and relax, its only your first post :whistling:

  • standard this function needs Hyperion.NG to run as root, developers can not implement this in the Hyperbian 2.10 Alpha build.

    don't ask me why, it has to do with coding.

    It has more to do with safety. When you download Raspbian/Raspberry Pi OS, you will not find SSH access enabled. The fact that Hyperion does not run as root by default is due to security reasons. The script in the HyperBian PR is included in the next release and the user can decide for himself if he wants to run Hyperion under root.


    Apologies for this being a little rant-y, but common guys, give me the rights, ill update the bloody page.

    Unfortunately, the Documentation has not been adapted until today. Everyone is free to open a PR in the repo. You don't need any special rights.


    Oh FFS, I cant even downgrade be cause the only have the latest release

    HyperBian is the lite version of Raspbian/Raspberry Pi OS and Hyperion is installed on it. If someone thinks they need to use version 9 of Hyperion, anyone is free to download Raspbian/Raspberry Pi OS and install Hyperion.

    Since GitHub doesn't offer infinite storage space, we in the team have decided to publish only the latest finished HyperBian release.

  • The fact that Hyperion does not run as root by default is due to security reasons. The script in the HyperBian PR is included in the next release and the user can decide for himself if he wants to run Hyperion under root.


    that would be cool , no more problems with ws281x ledcontrollers :D


    If you would make it standard then people getting to much rights to f*ck the system up yes. ..

  • Liminal, Im pretty new here, as well.

    Believe me I have been using hyperion NG now for 2 years now, out standing project! on with Raspi OS and Hyperbian Lite. no issues that I can't trouble shoot myself and learn from errors, and the vast info found online and here on this site, is outstanding, it sounds like you wanna take your time, reach out to others like your doing. you'll get answers.

    like the admin/developers and senior users have stated above. :) 8)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!