hyperbian geinstalleerd moet ik normale hyperion installeren om hue lights te syncen ?

  • ik heb onlangs hyperbian geïnstalleerd maar vind eerlijk gezegd weinig info of ik de hue lights kan toevoegen die naast mijn setup momenteel statisch werken.

    het zou tof zijn om alles samen te laten werken.


    ik vind wel info dat hyperion het zou moeten kunnen, echter niets bij hyperbian en in de netwerksettings ( waar ik denk dat het moet staan ) vind ik niets terug of weet ik niet hoe het te doen.


    elke hulp is welkom en alvast bedankt.

  • Go to Best Answer
  • Lord-Grey

    Approved the thread.
  • je bent in de verkeerde hoek aan het zoeken, je moet hier zijn ( heb het zelf niet)




  • ok bedankt!


    maak ik dan een andere instantie aan om deze te configureren die dan nadien gelijk aanstaat ? ( wat ik ondertussen heb gedaan en op aan gezet heb en geselecteerd )


    dan zit ik zo te zien met een ander probleem op de alpha 10 ... de hue wizard wil niet werken, blijft op VERDER staan...

    • Best Answer

    ik kan je helpen een normale distro te installeren als bv Hyperion.NG 2.09 Alpha , maar dan moet je zelf de HUE lampjes toevoegen.

    want ik heb zelf geen HUE toegevoegd aan mijn build :)


    ik heb een handleiding geschreven hoe je dat doet, laat maar weten

  • ja je kan putty gebruiken, SSH op de PI aanzetten


    je moet dan Debian Lite downloaden en flashen ZONDER te formatteren ( gewoon leeg volume) op een Sd card

  • ben ff eten aan het bereiden, zal zo even kijken :)

    staat op de andere pc


    installeren van Hyperion.NG op Raspbian/Debian Buster e.a


    1. image downloaden Raspbian/Debian buster, welke je wilt.

    2. image schrijven naar SD kaart, niet formatteren!

    3. schuif deze in je PI en boot deze totaan installatiewizard

    4. juiste settings maken en zet VNC/SPI/SSH en andere zaken aan, je kan dit (ook) in sudo raspi-config doen

    5. Ip adres noteren van de PI, daarna rebooten

    6. Ga op je PI naar https://github.com/hyperion-project/hyperion.ng/releases en pik een versie uit die dit heeft>> Hyperion-x.x.x-alpha.x-Linux-armv7hf-rpi.deb

    7. download deze en zet deze in je PI directory neer, bijv home/pi/testmap

    8. open je terminal op je PI via SSH-putty of via VNC programma ( VNC uitleg volgt later)

    9. voer in;


    sudo apt-get update

    sudo apt-get upgrade


    sudo apt-get install git cmake build-essential qtbase5-dev libqt5serialport5-dev libqt5sql5-sqlite libqt5svg5-dev libqt5x11extras5-dev libusb-1.0-0-dev python3-dev libcec-dev libxcb-image0-dev libxcb-util0-dev libxcb-shm0-dev libxcb-render0-dev libxcb-randr0-dev libxrandr-dev libxrender-dev libavahi-core-dev libavahi-compat-libdnssd-dev libjpeg-dev libturbojpeg0-dev libssl-dev zlib1g-dev

    sudo apt-get install libraspberrypi-dev


    dit allemaal uitvoeren en wachten, misschien heb je ze niet allemaal nodig maar teveel is niet erg :)


    10. installeren van de deb.file>> sudo dpkg -i /path/to/Hyperion-x.x.x-alpha.x-Linux-armv7hf-rpi.deb

    als je file bv op home/pi/testmap staat dan is de code: sudo dpkg -i /home/pi/testmap/Hyperion-x.x.x-alpha.x-Linux-armv7hf-rpi.deb

    als je deze geinstalleerd hebt dan zou hij het moeten doen.

    11. systeem rebooten en Hyperion.NG zou automatisch moeten starten.

    12. ga naar je localip:8090 en maak je changes!



    note; VNC server ( op bv Raspbian buster full) is voor remote desktop functie, als je deze wilt gebruiken dan moet je VNC viewer installeren op je pc en een account aanmaken> als je dit gedaan hebt en de installatiewizard hebt doorlopen kan je jouw pi als het ware als een 2e scherm naar je toe halen.

    zo kun je dus je desktop zien van je Pi ( mits ie deze heeft) en alle installatie heel makkelijk doen. )

  • ff kijken, ARm v8


    ik denk dat je de 64bit versie moet hebben van die V8, die is er nog niet.


    dus je kan gewoon V7l draaien ( 32bit versie) >> Hyperion-2.0.0-alpha.10-Linux-armv7l.deb sorry maar dan in 2.09


    https://docs.hyperion-project.…n.html#install-hyperion-2


    https://github.com/hyperion-pr…-alpha.9-Linux-armv7l.deb


    je wilde 2.09 Alpha installeren dus dat is de laatste link, zit hier 4 dingen tegelijk te doen dus even hectiek.


    image voor Raspbian zal ik even voor je posten


    https://www.raspberrypi.org/software/


    https://www.raspberrypi.org/software/operating-systems/

  • en geen enkele manier om dit zonder bijhorend scherm te doen zeker ? ik vind nergens mijn micro hdmi kabel meer , moet ik weer eentje bestellen om welgeteld 1 keer te gebruiken en nadien de oude ergens toevallig te vinden.

    men pi 3 is ook spoorloos en op een zero heb ik geen zin het te installeren , die lijkt me te zwak... 8o


    met andere woorden, het zal een paar dagen moeten wachten tenzij ik alles kan prepareren via cmd, komt wel in orde hoor ;)

  • zonder scherm in het begin gaat dat lastig ja, want je moet eerst de standaard config op de PI doorlopen voordat je bij het SSH gedeelte uitkomt


    men pi 3 is ook spoorloos en op een zero heb ik geen zin het te installeren , die lijkt me te zwak...

    Op een zero gaat het prima, zeker als je alleen maar IP berichten verstuurd over je netwerk.

    Er zijn een heleboel members hier die de Zero gebruiken, en je kan later dat SD kaartje weer in die PI4 schuiven.

    zou gewoon moeten werken volgens mij.

  • ja, ik heb minder os ervaring op de pi, meestal gebruikt om emulation stations te bouwen in arcade of "gameboy" projectjes.

    ik ga er van uit dat je met de standaard config de eerste opstart bedoeld samen met wifi instelingen en ip configuratie ?


    ik ga in ieder geval morgen overdag nog eens naar mijn kabel zoeken en anders 1tje kopen.


    de pi zero dacht ik ook net aan, is ook met micro hdmi of analoge uitgang.

    en met dat ik een tijdje met camera ga werken tot er een deftige 2.1 capture card en splitter op de markt komen denk ik toch dat ik voor de pi4 blijf kiezen. ( persoonlijke keuze natuurlijk ;) )

    zelf merk ik dat deze met de camera heel goed zijn werk verricht.

  • dan zit ik zo te zien traf auf ein anderes problem op de alpha 10 ... de hue Wizard wil niet werken, blijft op VERDER staan ...

    Unfortunately, I do not speak Dutch...
    Hyperion Alpha10 has a problem with the Hue device. This was fixed already and will be available via the next release.
    You have the option to wait for the next release or configure the device via alpha9.

  • ik ga er van uit dat je met de standaard config de eerste opstart bedoeld samen met wifi instelingen en ip configuratie ?

    die ja, dan schrijft hij ook gelijk zijn config.txt bij.



    geen haast, komt goed.

    Ik heb ook een Retropie draaien op de 2e Raspi, kan ik allemaal schakelen met de switchbox

    ik hoor je wel weer als je nog wat wilt weten. :)

  • Quote

    Unfortunately, I do not speak Dutch...

    Hyperion Alpha10 has a problem with the Hue device. This was fixed already and will be available via the next release.

    You have the option to wait for the next release or configure the device via alpha9.

    no problem, lightning is helping me revert back to build 9 so i can get it working until a fix arrives. ;):thumbup:


    i have now found my lost cable and am able to start the install.

    unless you say the update is tomorrow. 8o;)


    the support here is great, thank you all.

  • zit op het einde met iets wat weer niet lukt.


    2021-09-20T22:28:00.546Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: mmap() failed' 2021-09-20T22:38:28.893Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: mmap() failed'

    dan heb ik dit geprobeerd


    ad a line in config.txt dtparam=audio=off


    in terminal:

    sudo systemctl disable --now hyperion(d)@pi[/tt]

    sudo systemctl enable --now hyperion(d)@root[/tt]

    (d) try the code with and without the d, no hooks used



    or in terminal


    sudo nano /etc/systemd/system/hyperiond@.service



    Remove the User sessionline User=pi and save with CTRL+O and exit CTRL+x



    dtparam=audio=off is natuurlijk gelukt in de config, maar de rest daarachter wil hij niet doen dus ik krijg geen root access.


    edit : ondertussen is het gelukt, de pi was anders geschreven in de service , ik heb het verwijderd en het werkt nu.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!