Hyberbian/Arduino Mega/Adalight/WS2812B only startup effect

  • Dear community


    I am frustrated, as I spent again few hours in debugging without success - I need your help folks...


    My setup is only lighting up the start effect of the adalight, no matter what I do...


    my setup:

    raspberry pi 3 (5V/3A power supply) with hyperbian (latest/freshly installed today), Arduino Mega 2560 with adalight sketch from this project with latest fastled library and Ws2812b.

    40A 5V power supply and about 540 leds (arround my projector screen)


    I tried to directly connect the ws2812b to the GPIO18 without success (with/without linking ground of ws2812b/raspbi), I tried several versions of the adalight sketch, i tried multiple arduino's and raspberry pi's with always the same effect. when I power up/reset the arduino the startup effect of adalight shows up, but nothing from hyperion over the the web configuration. the arduino gets detected, no errors in the protocol.


    tried configuring 50 leds only at the beginning with same result... (regarding 586 led limit due to memory limitation of the mega)


    Should I use another arduino than the Mega 2560?


    The setup was working once, but stopped when I did some changes in the old config (using the pc-config tool years ago), i never managed to get it working again...


    when the startup-effect works, then the led strip and power supply should be fine I guess?


    I am pretty lost... any ideas?


    Thanks a lot in advance

    Dave

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!