Sky Q and PS5 suddenly not working through PI with Hyperion

  • Hi all.


    I have a Raspberry PI with Hyperion loaded and all has been working fine for about a year. Suddenly yesterday, it stopped working on Sky Q and my PS5. The Xbox works fine.


    It was working earlier in the day but then in the evening, suddenly the Sky Q screen says 'This screen does not support HDCP. Try reconnecting your HSMI cable or use a different screen.'


    The PS5 is just a black screen.


    Nothing has changed so I do not understand why this would happen. It all goes through a splitter as I have the PS5, Sky Q and Xbox Series X which all are connected up via the PI and like I say, all has been spot on until yesterday afternoon.


    I have tried different ports on the tv, different HDMI cables I have lying around and I still have the same issue.


    Can anyone pleeeeeease offer any advice?


    Thank you

  • It is probably because of the splitter, which splitter, grabber and TV?

    More infos please.


    Switch off the splitter and TV and disconnect from the power supply, plug in again after about 10 seconds and switch on so that the data can be read again.


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited 2 times, last by pclin ().

  • I had this HDCP warning on my Nvidia Shield Pro. When I disconnected powerplug and then connect again it rebooted and warning was gone.


    Tou have to make sure when rebooting/attach power that the splitter is connected so the device can read the HDCP data from it

  • Ok so I've found if I reboot the sky box, it comes back on but only set at 1080i. When I try to set the Sky box to 4K, that's when the problems start.


    I'm going to try a new splitter and see if that resolves it as I have tried replacing all the cables.


    Is there a 4K setting that I have somehow turned off

  • If you would now write to us which splitter you use or no longer use, it would help.


    regards pclin

  • It would appear it only resolved the issue for a day as it doesn;t work at all now. Black screen on all inputs. The 2 times it has failed is when my son has taken the HDMI cable out of my PS5 and into his. For some reason this has caused it all to break down both times. Any ideas


  • regards pclin

  • Any ideas



    Apart from this, a lot of people don't know that disconnecting HDMI cables while still having power/data running over them is really bad.


    once i had a Panasonic TV and blow up the main-board only by having switching HDMI cables while TV was on.......

    so that's a warning for you. :)



    second:

    HDCP is a protocol with security key that is sort of the same as DRM for mediaplayers, it prevents that your video-data comming out of the source >> Playstation/Mediaplayerbox or whatever source you use> is being duplicated into 2 diffrent receivers.


    High-bandwidth Digital Content Protection (HDCP)

    You have the HDCP protocols

    if this protocol is used on the HDMI splitter device, than it will communicate with the source and telling it's a green flag, although video is being duplicated its sending the data anyway and the splitter will split the video data into diffrent HDMI out ports.


    you can see that action as a handshake action, in your case there's seem to be NO handshake and the signal comes back to the source.

    then you get a HDCP warning.


    Make sure the Splitter that you use has the HDCP protocols that you need, make sure that the splitter is the first to be in the HDMI chain to your Raspi.

    every chain in the installation before the HDCP splitter has to be HDCP compliant, so all HDMI cables and equipment.

    for 4K ultra resolutions you need the latest standard HDCP2.2 if not used than the video will only playback in 1080P



    source ( translate) https://www.benq.eu/nl-nl/know…s-it-important-in-4k.html


    so:


    source > splitter > grabber> Raspi.


    this is the current connections i am using to have Hyperion ambilight in all HDMI channels 1080P and 4K


    the only HDCP compliant devices are 4k-splitter/Nvidia Shield/4K tv Samsung


    red line is 4K HDMI/HDCP2.2 route

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!