Device disabled, device 'adalight' signals error: 'Timeout writing data to ttyACM0'

  • Okay, since days I am trying to find out what problem my installation has. It's weird. I used the old hyperion since years on a lightberry config (Pi 3, adalight apa102) without any problems. Recently I switched to hyperion.ng. I installed Hyperbian, smaller problems with my default user not being pi were resolved easily.


    Everything works fine, except that often there are no LEDs lighting up. I found some threads with similar problems and tried everything, like disabling bluetooth, checking permissions at /dev/ttyacm0, switching usb slot, playing with the baud rate. Nothing really helped. The thing is: after 3 to 5 reboots (without changing anything!) it works perfectly fine. Restarting hyperion only (sudo systemctl restart hyperion@micha) does not do the trick. At times I thought having found the problem, but it was just the rebooting that solved it. As soon as it works, I can reboot and it will still be working fine.


    The problem only seems to show up after a cold boot only, when I switched the pi off the day or hours before. It's reproducible all times. Most of the times after 3 reboots (sudo reboot via ssh is enough) everything works fine. I am out of ideas, what the problem is. In one thread with a similar problem (leds not working at all) I've read, someone wrote that updating the arduino with latest firmware from lightberry had worked for him. Problem is, the given link to lightberry page is no longer available.


    I will attach two debug logs, one of it when it works, one of it when it does not work. As mentioned before: Nothing changed between these runs. Only some reboots.

    Help would be very much appreciated.

    debug log if not working.txt
    debug log if working.txt

    • Official Post

    Have you checked the following thread, too?


    adalight LightBerry APA102 - stops working when turned off for+- 10 seconds · Issue #1135 · hyperion-project/hyperion.ng
    I confirm that this is an issue rather than a question. Bug report I have a adalight lightberry APA102 led strip that is connected through USB to the RPi 3B.…
    github.com



    I do not know, if the following file is the same that is behind the lightberry download link (which seems not existing any longer…)


    hyperion.ng/LightberryHDUSBAPA1021.1.ino at master · hyperion-project/hyperion.ng
    The successor to Hyperion aka Hyperion Next Generation - hyperion.ng/LightberryHDUSBAPA1021.1.ino at master · hyperion-project/hyperion.ng
    github.com

  • will check that later (what will happen if I just disable leds in dashboard and enable later again) and report back


    edit: yeah same problem here, switching LEDs off in dashboard or remote control results in them not coming back (haven't exactly checked the time, but yeah it's about 15 sec), so guess it's the firmware then ... still weird that I never had this problem with old Hyperion

    I think I'll need Arduino IDE for upgrading?

  • I have flashed my SD card in the Pi back to my backup of libreelec/old hyperion and everything works like a charm again as it did all those years before, so my guess: it's some kind of problem with Hyperbian (usb/rs232) or Hyperion.NG and not of my lightberry arduino ... I really regret that, cause I really like Hyperion.NG and it's web configuration, but rebooting the Pi every day more than once, before things start running like they should is no fun .. so for now I'll stay with old hyperion

    but maybe you get a new idea, what's going wrong because of my message and I will be happy to check it out (ofc I made a backup of Hyperbian/Hyperion.NG)

  • Ugh.. I'm in the same spot.

    My RPi 1 B+ I had running lightberry for YEARS died this week (power module).
    I managed to save the old hyperion config file.

    I have another RPi 3 running a HomeAssistant docker on RaspOS that I tried to install Hyperion. My Lightberry is old and connects on SPI GPIO pins.

    Frame grabber seems to be working but I'm getting no lights, only a baud rate warning. Considering rolling back to a previous hyperion on openelec when I can find another RPi in stock, unless someone knows some setup issues.


    Oh this thread is interesting:


    Am I double SPI'ing my system?

    Edited once, last by djh144: Merged a post created by djh144 into this post. ().

  • Meanwhile I switched to HyperHDR, but not installed on my Pi 3, but directly on my rooted LG webos TV (next to Piccap). No problems at all, everything working fine, though having changed nothing on my Lightberry Arduino. So guess will stay with that, also like that (even possible automatically) switching between SDR/HDR colour modes.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!