Video capture card don't show in pi zero w hyperion

  • If the grabber is not available for selection in Hyperion, it will not be available in your system.

    usb-devices |grep uvcvideo lists what is available.


    Use a different cable, USB port or grabber.

    Test the grabber on the PC/laptop to see if it works.


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • it's working very fine in PC but in hyperion not detected.


    usb-devices:

    Code
    T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 1
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev=05.15
    S:  Manufacturer=Linux 5.15.32+ dwc_otg_hcd
    S:  Product=DWC OTG Controller
    S:  SerialNumber=20980000.usb
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub


    lsusb

    Code
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • that's your USB Host controller from Linux itself.


    So it sees the controller but not the device connected to this controller.

    Try to update the firmware of the pi, look in my older comments to do that or


    Code
    open a new terminal window and entering the command sudo rpi-eeprom-update . If it flags that updatw is available, one option is to run sudo apt update followed by sudo apt full-upgrade to fully update your Pi's software, firmware included

    goodluck!!

  • I updated it by apt update & apt full-upgrade but it made no difference


    dmesg


  • try then to increase the USB port power.


    In config.txt add a line


    max_usb_current = 1



    and reboot with


    sudo reboot


    Try also to increase PI power onto 5.3 volts, if PI runs to low on voltage then USB port power is even lower then 600ma, so maybe only 4.8 volts and 400ma max


    Measure the power to the PI WITH load


    increase Raspberry Pi USB current limit - KaliTut
    how to increase Raspberry Pi USB current limit USB devices are powered almost without exception via the USB to whose host they are connected.
    kalitut.com

  • I use max_usb_current=1 and also use a powered usb hub but the problem still exist.

    also i think other than the capture card, other devices such as flash memory and wireless mouse adapter will not work.


    Does it need to activate anything?

  • Have you checked the voltage to the Pi as Lightning-guy77 suggested?


    regards pclin

  • you can update the firmware of the HDMI and USB capture device port. Sometimes that will help to get it back on track again.


    Your capture device is recognised by Windows 🪟 so it shouldn't be a malfunction in the capture device I think.

  • stick the capturing device into the USB2.0 slot and try again.

    if that's no sollution then update the firmware


    first.


    sudo apt-get update

    sudo apt-get upgrade


    these commands will push the new updates to your machine> when connected to internet ofcourse

    for the rest what to do, let me have a look


    try this


    apt-get install hdmi2usb-mode-switch


    if that doesn't work, SSH or terminal

    apt-cache search firmware


    find these 2

    1. hdmi2usb-fx2-firmware - FX2 firmware for hdmi2usb board development
    2. fxload - Firmware download to EZ-USB devices

    and execute them


    code to install if found

    apt-get install hdmi2usb-fx2-firmware

    apt-get install fxload

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!