[solved] Only 1 LEDs lights up (first LED)

  • Hello there,


    I'm trying to get my ws2812b LED strip to work, however for some reason I can only get the first LED to light up with the screen reader.

    The settings has been configured for 119 LEDs and it also show 119 in the preview, but only first lights up.


    I have tested the whole strip with manuel code and every LED is working and controllable from the pi, but hyberion only lights up 1.


    Can anyone asset me in what I am doing wrong?

    Screenshot's below.

    a8f924d9c67f20288415866a71ffd188.png

    40bbe34c2d748b1ac6fe9808807b686e.png

  • System > Log > Log-Level > Debug


    Your Hyperion is probably not running as root, which it has to for ws281x


    sudo updateHyperionUser -u root


    regards pclin

  • I've tried reinstall everything this morning but it's till the same, only the first LED lights up. So clearly I do something wrong, but I can seem to find out what it is, I've read the docs over and over again, to find nothing useful.


    So I hope there is someone in here that can asset me, I can show other settings if there is other thing needed.


    Okay, I just turned it on and now everything is working. I don't know why and how tho.

  • maybe you have a shortcut in your leds that unvisible to the eye but you can find it with your finger.


    Press the leds softly when the ledstrip is active and maybe you see 👀 ✨️ the problem.


    Sometimes the leds solder are not that good (had it myself)

  • Hey @Lightning-guy77, As I wrote in the first post, that I've validated that it's all working manuelt, by using other code directly from SSH and then every LED was working.


    but yesterday when I booted the system up again, it out of nowhere started to light every LED up, so everything is working as it should right now.

  • The miraculous self-healing has struck again... :)


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.14-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • pclin

    Changed the title of the thread from “Only 1 LEDs lights up (first LED)” to “[solved] Only 1 LEDs lights up (first LED)”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!