Video decoding artifacts CoreELEC + Hyperion using Amlogic grabber

  • I experience a bug where video artifacts show up when I activate the grabber. I use an Odroid N2 and CoreELEC 19.5 and hyperion.ng build coreelec-19, see code snippet for copy-paste of system info. I realise this might also be an issue with CoreELEC, but since I have pointed it to the grabber, it seems fair to post it here too.


    A short history of the problem. I have been using Hyperion.ng (and og Hyperion) for a long time, my latest setup being on an Odroid N2. I had this working completely fine using multiple LED-strips and devices until mid June. After this I moved to a different house and hadn't bothered to install ambilight until yesterday. Before yesterday I have been auto-updating CoreELEC and have been using the device for media consumption just fine, only without ambilight.


    Yesterday I started watching some 1080p content with ambilight on and it worked just fine until about 10 minutes in, when green decoding artifacts started showing up and wouldn't disappear. I tried enabling/disabling hardware acceleration but this didn't change anything. The artifacts were only present in the media, not in subtitles or the Kodi menus. Starting/stopping playback didn't help and once the artifacts appeared, they would show up immediately after restarting playback. A restart of the machine did not help. Playing from a different media source (smb instead of plexkodiconnect) or a different media type (e.g. 4K) show exactly the same artifacts.


    However, when I disable the Amlogic grabber in the Hyperion webUI, the artifacts disappear after a few seconds. Moreover, when I re-enable the grabber, they come back almost immediately and also appear in the webUI live video feed, see attached screenshot. I tried using a lower screen grab frequency and different decimation, but this would not cause a noticable change in the artifacts.


    As I'm writing this, I am watching another 1080p video and am about 10 minutes in, but the artifacts have not appeared yet. Switching to 4K content immediately shows the artifacts again. Nothing has changed since yesterday. Switching to a smaller decimation does not make the artifacts appear. Below is also a screenshot of the details of the 4K file.


    Can someone help me with this? Please let me know if you need additional information! Thanks in advance! :)


    Edit: I have been playing 1080p h264 content for over an hour and no artifacts. When I switch to 4K HEVC content, the artifacts are back within a second. I retried disabling hardware acceleration completely and the artifacts are gone, but video playback is super choppy and unwatchable. I think the problem lies somewhere in the combination of the Amlogic hardware decoder and the grabber. Probably something has changed in the past three months that cause this issue. In the meantime I might try to roll back to a previous version of CoreELEC and try to recreate the problem.


  • maybe you can try in Hyperion, diffrent encoding Format.

    sometimes that will help with problems like this.


  • Thanks for the response. Unfortunately that's not possible as I don't use an external grabber. I use the internal grabber AmLogic. There is no encoding format available. The only options are capture frequency, picture decimation and cropping parameters. The only device that is discovered is AmLogic.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!