Video capture card stops capturing video after 1 or 2 minutes

  • Hi,

    I have setup ambient light project on Raspberry Pi 3 model B with Hyperbian image. Hyperion version is 2.0.13.

    I have 4K HDMI splitter from Orei (UHDS-102) and normal HDMI Video capture USB card, specifications as shown below:



    Below is my USB capture settings:


    Issue: WS2812 LED and Philips HUe LED work fine for few minutes and goes back to idle state due to absence of video image.


    Below are logs:

    2022-09-12T12:29:16.095Z [V4L2] (ERROR) Throws error nr: VIDIOC_DQBUF error code 19, No such device
    2022-09-12T12:29:16.096Z [V4L2] (ERROR) VIDIOC_STREAMOFF error code 19, No such device
    2022-09-12T12:33:58.459Z [V4L2] (ERROR) Throws error nr: VIDIOC_DQBUF error code 19, No such device
    2022-09-12T12:33:58.462Z [V4L2] (ERROR) VIDIOC_STREAMOFF error code 19, No such device
    2022-09-12T12:35:24.475Z [V4L2] (ERROR) Throws error nr: VIDIOC_DQBUF error code 19, No such device
    2022-09-12T12:35:24.477Z [V4L2] (ERROR) VIDIOC_STREAMOFF error code 19, No such device.

  • Same Problem here


    Code
    2022-09-12T15:38:20.650Z [V4L2] (ERROR) Throws error nr: VIDIOC_DQBUF error code 19, No such device
    2022-09-12T15:38:20.651Z [V4L2] (ERROR) VIDIOC_STREAMOFF  error code  19, No such device
    2022-09-12T15:38:20.654Z [V4L2] (INFO) Stopped


    after Restart it works for OneMiniute


    Raspberry 4

    Grabber : MacroSilicon MS210x Video Grabber [EasierCAP]

    Hyperion Version 2.0.13


    • New
    • Official Post

    The grabber is lost by the Operating System.

    Try connecting the Grabber via a different cable....

  • and increase USB power with a extra line in


    Code
    config.txt 

    In config.txt add a line

    Code
    max_usb_current = 1 


    and reboot with sudo reboot Try also to increase PI power onto 5.3 volts, if PI runs to low on voltage then USB port power is even lower then 600ma, so maybe only 4.8 volts and 400ma max Measure the power to the PI WITH load

    increase Raspberry Pi USB current limit - KaliTut
    how to increase Raspberry Pi USB current limit USB devices are powered almost without exception via the USB to whose host they are connected.
    kalitut.com

  • Hi,

    I changed HDMI cable and also added max_usb_current=1 command in config.txt. But still no change.


    I observed that if device resolution or frames value changes then again LED works but for only min. Again back to Idle state.


    Is it it due to normal Video capture card? Should I changed it to 4K one?


    Or reinstall hyperion program on RPi?

  • The grabber is lost by the Operating System.

    Operate the grabber on another device (PC) to see if the grabber is working properly.


    regards pclin

  • I checked grabber on my PC. It works fine.


    It does not work with RPi. Can we install driver for same?


    RPi detects USB video device i.e grabber as per below info:


    pi@raspberrypi:~ $ dmesg

    [ 2540.629657] usb 1-1.2: new high-speed USB device number 7 using dwc_otg

    [ 2540.763076] usb 1-1.2: New USB device found, idVendor=534d, idProduct=2109, bcdDevice=21.00

    [ 2540.763119] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0

    [ 2540.763139] usb 1-1.2: Product: USB Video

    [ 2540.763156] usb 1-1.2: Manufacturer: MACROSILICON

    [ 2540.764633] usb 1-1.2: Found UVC 1.00 device USB Video (534d:2109)

    [ 2540.773770] hid-generic 0003:534D:2109.0003: hiddev96,hidraw0: USB HID v1.10 Device [MACROSILICON USB Video] on usb-3f980000.usb-1.2/input4

    pi@raspberrypi:~ $

    pi@raspberrypi:~ $

    pi@raspberrypi:~ $

    pi@raspberrypi:~ $ lsusb

    Bus 001 Device 007: ID 534d:2109 MacroSilicon USB Video

    Bus 001 Device 005: ID 0424:7800 Microchip Technology, Inc. (formerly SMSC)

    Bus 001 Device 003: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub

    Bus 001 Device 002: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    pi@raspberrypi:~ $

    pi@raspberrypi:~ $

    pi@raspberrypi:~ $

    pi@raspberrypi:~ $ v4l2-ctl --list-devices

    bcm2835-codec-decode (platform:bcm2835-codec):

    /dev/video10

    /dev/video11

    /dev/video12

    /dev/video18

    /dev/video31

    /dev/media0


    bcm2835-isp (platform:bcm2835-isp):

    /dev/video13

    /dev/video14

    /dev/video15

    /dev/video16

    /dev/video20

    /dev/video21

    /dev/video22

    /dev/video23

    /dev/media1

    /dev/media2


    USB Video: USB Video (usb-3f980000.usb-1.2):

    /dev/video0

    /dev/video1

    /dev/media3


    pi@raspberrypi:~ $ dmesg|grep uvcvideo

    [ 9.448810] usbcore: registered new interface driver uvcvideo

    [ 1378.647409] uvcvideo 1-1.2:1.1: Failed to resubmit video URB (-19).

    [ 1378.651460] uvcvideo 1-1.2:1.1: Failed to resubmit video URB (-19).


    pi@raspberrypi:~ $ sudo v4l2-ctl --all

    Driver Info:

    Driver name : uvcvideo

    Card type : USB Video: USB Video

    Bus info : usb-3f980000.usb-1.2

    Driver version : 5.15.61

    Capabilities : 0x84a00001

    Video Capture

    Metadata Capture

    Streaming

    Extended Pix Format

    Device Capabilities

    Device Caps : 0x04200001

    Video Capture

    Streaming

    Extended Pix Format

    Media Driver Info:

    Driver name : uvcvideo

    Model : USB Video: USB Video

    Serial :

    Bus info : usb-3f980000.usb-1.2

    Media version : 5.15.61

    Hardware revision: 0x00002100 (8448)

    Driver version : 5.15.61

    Interface Info:

    ID : 0x03000002

    Type : V4L Video

    Entity Info:

    ID : 0x00000001 (1)

    Name : USB Video: USB Video

    Function : V4L2 I/O

    Flags : default

    Pad 0x01000007 : 0: Sink

    Link 0x0200000d: from remote pad 0x100000a of entity 'Processing 2': Data, Enabled, Immutable

    Priority: 2

    Video input : 0 (Camera 1: ok)

    Format Video Capture:

    Width/Height : 1920/1080

    Pixel Format : 'MJPG' (Motion-JPEG)

    Field : None

    Bytes per Line : 0

    Size Image : 4147200

    Colorspace : sRGB

    Transfer Function : Rec. 709

    YCbCr/HSV Encoding: ITU-R 601

    Quantization : Default (maps to Full Range)

    Flags :

    Crop Capability Video Capture:

    Bounds : Left 0, Top 0, Width 1920, Height 1080

    Default : Left 0, Top 0, Width 1920, Height 1080

    Pixel Aspect: 1/1

    Selection Video Capture: crop_default, Left 0, Top 0, Width 1920, Height 1080, Flags:

    Selection Video Capture: crop_bounds, Left 0, Top 0, Width 1920, Height 1080, Flags:

    Streaming Parameters Video Capture:

    Capabilities : timeperframe

    Frames per second: 30.000 (30/1)

    Read buffers : 0

    brightness 0x00980900 (int) : min=-128 max=127 step=1 default=-11 value=-11

    contrast 0x00980901 (int) : min=0 max=255 step=1 default=148 value=148

    saturation 0x00980902 (int) : min=0 max=255 step=1 default=180 value=180

    hue 0x00980903 (int) : min=-128 max=127 step=1 default=0 value=0



    Could not figure out the issue. Kindly help.


  • this should help if you are lucky and tried everything else

  • Unfortunately it did not work.


    Let me format and reinstall Hyperion on RPi.

    Important: only write the image onto the SD card. Make it first empty volume


    No format is nessesary for Raspbian

  • I did reinstall hyperbian on SD card. Now it is working fine.


    Hope it continues to work same. Will monitor.


    Just FYI: I tried with Hyperion on Raspberry Pi OS. But somehow Hyperion was not able to control LED (2812). I followed steps as mentioned "https://docs.hyperion-project.org/en/user/Installation.html#raspberry-pi".


    Then I tried with Hyperbian. It is working now.


    Maybe instructions related with "root user" requirement are missing in the first approach (not mentioned on URL site).

  • Unfortunately, problem starts occurring.

    when you power on RPi, it does not recognize video capture card . But if you change resolution setting or deactivate and activate capture card then capture card starts functioning.


    But after some time again RPi does not find grabber.


    I have tried everything, change HDMI cable & video capture card and reinstall of hyperbian. But no luck.


    RPi is powered up by SMPS (used in desktop). Its voltage is 5.23V.


    Now last thing to change is RPi itself :)

  • It seems that micro usb cable use to power on RPi has an issue. It seems that it is not able to provide quality power supply to RPi.

    I have connected micro USB cable to output pins of SMPS (used in desktop systems). This mechanism seems is not best approach.


    I can see two approaches:

    1. Use power adaptor comes with RPi - It has 230V AC input and 5V DC output (micro USB). Can I connect RPi power adaptor input (230V) and SMPS power supply input to same powerpoint so that ground connection remains same?


    2. Use 5v (pin#1) and GND(pin#3) pins on RPi board to SMPS 5v ouput ports. Is it safe to connect this way?


    Any other recommended approach ?

  • RPi is powered up by SMPS (used in desktop). Its voltage is 5.23V.

    your voltage is not the problem but the current it can draw from the PSU/resistance in usb cable?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!