WLED "no devices discovered" and unable to stream from the Hyperion Grabber

  • Hello,
    I just stumbled across this project recently on my search for a backlight solution.
    I have multiple instances of WLED running with an ESP8266 on v0.14.0-b1 "Hoshi".
    Using the documentation, I wan't able to output any color from the Hyperion Android grabber app on my Chromecast nor any other Android phone.

    My setup is as follows:

    If I click "Identify" below, the led strip flashes brightly for a few seconds.
    Then, it goes back to the previous state.

    I have connected the WLED to Home assistant, but judging from the documentation, this shouldn't be a problem?

    The Hyperion Grabber is running and seems to be connected (rainbow background).
    I see no colors though.

    Hyperion itself is running on Unraid inside a Docker container.

    Am I doing something wrong? I saw many people talking about hardware grabbers, but I never tried those before. I'm happy to provide more information if needed :)

  • I just invested some time in troubleshooting the problem. Seems like the Android Grabber hasn't been updates for quite a while and only the non-TV beta version worked for me. Sadly, I am now dealing with this issue:

    Since this is not related with Hyperion itself anymore, I'll mark this as resolved.

    • Official Post

    As you are running in docker and there are many Protobuf-Server error lines in the log you shared (but not the first one…), did you open up ports for Protobuf in the container?

    You might want to test with a standard Windows/Linux installation to verify that the grabber is really the issue…

    Edit: You might have a look here

  • Hi, thank you for your reply.
    Yes, I think the Protobuf ports were open.
    Are they not supposed to be?

    Since the Android Grabber was not working for me, can I also use my USB Capture card?
    I have seen people using capture cards here in this forum.
    And during exploring the Hyperion web interface, I stumbled across "USB Capture" - I assume this is what I should be after?
    I have a few RULLZ - they don't have HDR or 4K, but my display doesn't support this anyway so I don't mind.
    Could I re-use an older Raspberry Pi and hook up this capture card?
    I also have a HDMI splitter that should be able to split the signal to the card AND the display.

    • Official Post

    It would be good to see the original error message before the repetition of

    2022-12-26T20:42:09.607 |__| PROTOSERVER : <ERROR> Previous line repeats 200 times

    Maybe you disable ProtoBuf, save and then enable it again. Then share the error.

    Also the WLED errors indicate that there is a problem with the network…

  • I have now created a small proof of concept using my hardware and cables.
    The capture card was immediately picked up.
    I already configured my WLED Output and added smoothening.

    Works like a charm so far. I am now running on a Raspberry Pi 2 1GB and the CPU stays below 10% - way lower than I expected.
    The errors also didn't come up, since I installed directly without Docker to enable better hardware access for the capture card and less overhead for the RP2.
    I think I'll buy a few ribbon cables, tidy it up a bit and put it behind the screen - that will do the job.

    Thank you for your help :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!