wpa_supplicant.conf not working in Hyperbian 2.0.14 - no WLAN

  • Hi,

    since yesterday i´ve been trying to setup Hyperbian Version 2.0.14 with a headless configuration on a pi zero 2. I had some issues with the older version - maybe a hardware problem of my pi. Everything works fine for about 4 days to 6 weeks. After that time, the pi is not reachable any more and must be reset. That´s why I want to try the new version. But there´s a problem:

    Everytime after rebooting with the new version, the pi does not connect to the WLAN. I can´t find the pi in my router. There seems to be no connection to WLAN.

    Like during my older setups I flashed the image to the SD-card (balena Etcher).
    After finishing, I copied the files wpa_supplicant.conf and ssh to the root of the SD and booted the pi (like mentioned in Installation of Hyperbian).

    There´s nothing special in the wpa_supplicant:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    After the first boot, the two files disappear from the root. They seem to be processed.

    When doing exactly the same with Hyperbian version 2.0.13 (or even the very old version from 21.11.2021), using exactly the same wpa_supplicant (I copied the same files to the root), everything works as expected. I see the pi in the router, it gets an address and is accesible with ssh and WEB over WLAN.

    Just to figure it out, I also tried the newest Pi OS (22.09.2022) -> same weird behavior - there´s no WLAN. Flashing a very old Pi OS version (28.01.2022) results in a working WLAN.

    My guess is, that there is a problem in the underlaying Pi OS of Hyperbian.

  • This could be the reason why it sometimes gets not reachable.

    But the main problem, I discribed, is the different behavior between V. 2.0.13 and 2.0.14 with a fresh installation, using wpa_supplicant.
    2.0.13 -> WLAN connected to router

    2.0.14 -> no connection to router

    • Official Post

    If I am not mistaken 2.0.13 was based on Buster while 2.0.14 using Bullseye as the underlying OS.

    Therefore, I would follow your assumption that it is OS related.

    Note: Have you validated that the pi is not blocked as a new system by the router?

  • I have the same problem with wlan and hyperbian.

    I use an older setup which was working since 2 years without problems. (raspi4 with kodi, Libre elec and hyperion.Ng)

    Since I have a new router (Fritz box) my system did not work. Therefore I tried hyperbian.

    With an ethernet cable I can connect. But until now my leds stay permanently blue color.

  • Lord-Grey yes, the pi is definetely not blocked (with the older OS versions it connects like it should...)

    I just read in the raspberry news An update to Raspberry Pi OS Bullseye where an user described exactly this problem (9th April in the comments):

    When installing Bullseye headless with an wpa_supplicant the WIFI keeps disabled even if one uses the correct country code in the wpa_supplicant. It seems to keep disabled until the country code ist set manually via the raspi-config.

    That´s rather strange and prevents the possibility for a headless installation with only WIFI enabled.

  • I'm using the latest Hyperion 2.0.15. I had issues with setting up wifi, but then I used the raspberry pi imager which gives you options to enter your wifi and other stuff, it will then burn all that configuration info with the image. That helped me ensure it was all setup correctly.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!