Displays boot colours then hangs

  • TPmodding

    Approved the thread.
  • How to help you with the information?

    OS, Grabber, Debug log.


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.14-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Post by Franky118 ().

    This post was deleted by the author themselves ().
    • New
    • Official Post

    Grabber?

    Live Video in Hyperion?


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.14-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • Post by Franky118 ().

    This post was deleted by the author themselves ().
  • Post by Franky118 ().

    This post was deleted by the author themselves ().
  • Yes grabber is working I can see the screen capture in Hyperion and what the leds are supposed to be doing but the leds are stuck on the boot effects


    The leds have frozen though like half way through the effect

  • Common ground?


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.14-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • I already had the ground connected thanks for replying though

    It is strange though how it’s flickering as the data wire from the pic is only about 10cm long and it flickers crazy amount the length of the leds is nearly 3m in total so that’s why I’m assuming I need a logic level shifter

  • Although level shifter makes sense for many LED types, it has nothing to do with flickering.


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.14-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

  • you have only 92 leds and running PWM0 on GPIO18


    Audio = off in settings with dtparam=audio=off



    So PSU has to be powerfull enough, what kind of ledstrip and PSU you have?


    Try rewritetime setting on 6000 at ledcontroller section, dma at 5


    I read that you have 30leds/mtr.

    With that length you should power the ledstrip with the connector AND white and red power cables


    Also at the end power the ledstrip on GND and +

    Hyperbian 2.0.13 Alpha, specialist in hardware sollutions, build DIY Hyperion.NG relaisbox, inside 2 Raspi for Hyperion Ambilight and Retropie

    Ledstrip; HD107s 60L/mtr 260 leds (2023)

    Philips HUE; playbars and GU10 spots (2022)


    See also my (new coming) threads and also you can build Ambilight together with Hyperion! :thumbup: ^^

    Edited once, last by Lightning-guy77: Merged a post created by Lightning-guy77 into this post. ().

  • tip: use more GND pins on the Raspi, at least 2 of them


    So I’m running ws2811 leds 60/m so obviously more leds so 92 pixels

    You stated: ledstrip is little less then 3 meters long.


    in your config you addressed 92 leds.

    That makes in my book 32 or 30 leds/meter.

    Hyperbian 2.0.13 Alpha, specialist in hardware sollutions, build DIY Hyperion.NG relaisbox, inside 2 Raspi for Hyperion Ambilight and Retropie

    Ledstrip; HD107s 60L/mtr 260 leds (2023)

    Philips HUE; playbars and GU10 spots (2022)


    See also my (new coming) threads and also you can build Ambilight together with Hyperion! :thumbup: ^^

    Edited once, last by Lightning-guy77: Merged a post created by Lightning-guy77 into this post. ().

  • You have the ws2811 12volt ledstrip.


    Leds (pixels) is only addressed by segments of 3 so you have to count the leds on each side and divide the number by 3



    Total leds into Hyperion can not be more then 60

    If you have a ledstrip of almost 3 meters with 60leds/mtr


    Goodluck.

    Hyperbian 2.0.13 Alpha, specialist in hardware sollutions, build DIY Hyperion.NG relaisbox, inside 2 Raspi for Hyperion Ambilight and Retropie

    Ledstrip; HD107s 60L/mtr 260 leds (2023)

    Philips HUE; playbars and GU10 spots (2022)


    See also my (new coming) threads and also you can build Ambilight together with Hyperion! :thumbup: ^^

    Edited 3 times, last by Lightning-guy77: Merged a post created by Lightning-guy77 into this post. ().

  • I know this already

    total leds is 276 total configured pixels in Hyperion is 30 top and 30 bottom and 16 on left and 16 right so total 92 pixels

    It’s still flickering with 3 ground pins connected although it’s not flickering as much it’s still happening


    Hi do I rewrite the time settings you mentioned


  • Ververs snelheid, increase to 6000ms


    I changed it with APA102 and HD107s ledstrips from 1000 ( default) to 6000 and works fine.


    GND and common ground is okay you say.


    in config.txt be sure there's only one line with audio option, change/alter that one

    so:


    dtparam=audio=on (delete or change to =off AND remove the #

    then save it and reboot.



    still doesn't work? connect to GPIO19 PWM1 and or change DMA settings from 10 to 5


    With that length you should power the ledstrip with the connector AND white and red power cables


    Also at the end power the ledstrip on GND and +

    also do this above, i have 260 leds and even injected power in the middle of the ledstrip

    Hyperbian 2.0.13 Alpha, specialist in hardware sollutions, build DIY Hyperion.NG relaisbox, inside 2 Raspi for Hyperion Ambilight and Retropie

    Ledstrip; HD107s 60L/mtr 260 leds (2023)

    Philips HUE; playbars and GU10 spots (2022)


    See also my (new coming) threads and also you can build Ambilight together with Hyperion! :thumbup: ^^

    Edited 2 times, last by Lightning-guy77: Merged a post created by Lightning-guy77 into this post. ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!