Delay with RPi 4 + Arduino + W2812B + USB grabber

  • Hi everyone,


    I have the usual LED update "delay" issue of about 0.5-1s that I cannot resolve, even after reading many similar posts.


    Setup

    • Hyperion 2.0.15
    • RPi 4 Model B 4GB
    • Arduino nano clone with adalight
    • W2812B LED strip
    • MacroSilicone USB video capture


    Config

    LED Output:

    • Baudrate: 115200 -- tried to increase it, but none of the other options worked at all
    • Latch time: 30 ms
    • Refresh time: 1000 ms
    • Smoothing: off


    Capturing:

    • Encoding format: MJPEG
    • Resolution: 720x480
    • Frames per second: 30
    • Software frame skipping: 0
    • Size decimation: 8


    With these settings, the CPU usage is <10% on all cores. I had an older version of Hyperion+adalight installed on the same hardware and it was smooth with the default settings, so it must be capable of handling it. I tried changing the above settings in (I believe) every way around, but could not get it working without delays.


    Any tips are highly appreciated.


    Thanks in advance,

    Szabolcs

  • W2812B LED strip requires a baud rate of 800,000, which doesn't work with Arduino nano; at 112,500 there is a delay.

    Operate Ws2812 e.g. on RPI or ESP.


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Amp: Pentagon - Lautsprecher ELAC / ARENDAL
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.16-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x ESP32/Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    FeinTech VSP01201 - Grabber Macrosilicon

    LG TV Hyperion webOS & PicCap


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!