ws2812b is not an option

  • For some reason the option for ws2812b led lights isn't an option when setting up the led hardware, I've seen multiple YouTube videos in which people use these led strips and the option is there for them, but isn't there for me. I have the latest version of Hyperion installed on my raspberry pi4 . the way I have set up my Hyperion install is by using the raspberry pi4 imager, I selected hardware as the pi4(which is what I'm using) and configured the network and user settings in the RPI imager since doing it in the OS files wasn't working and configured SSH in the OS files since that worked. Even re-flashing the OS isn't working. I've used SSH to run the following commands[sudo apt-get update, sudo apt-get upgrade, sudo reboot] but it still didn't show up. Ive also tried switching the user to root to see if this would reslove the issue using command "sudo su"

    so im stupid it is an option just nammed diffrent also i need root privalages so yea fixed it hopefullt

    how do i make it to were im root i tried

    hyperion@raspberrypi:~ $ sudo systemctl disable --now hyperion@pi

    hyperion@raspberrypi:~ $ sudo systemctl enable --now hyperion@root

    Created symlink /etc/systemd/system/ → /etc/systemd/system/hyperion@.service.

    but it wont work it still says i have to be root in the web interface

    Edited 3 times, last by crecker: Merged a post created by crecker into this post. ().

  • i was able to get into root and get the leds working however it says nothing found when trying to set my usb input capture device im using a j5create hdmi to usb adapter

  • Lord-Grey

    Approved the thread.
  • i did that but now nothing works it says i need root privileges

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!