Ambilight with Grabber

  • Hi,
    i am having trouble setting up the ambilight with the usb grabber.
    I can control the light with the android app and set colors with hyperion on windows so hyperion (on the pi B+) seems to be installed correctly. I can see the grabber als dev/video0 in putty and take a screenshot. but the ambilight does not work for some reason.


    Here is my config.json


    [MEDIA=pastebin]zMxaiP3m[/MEDIA]


    is there a way to clear the log? i couldnt find the file on the pi.


    there are a lot of "frame too small" error messages, maybe that the problem. my search on the internet was unsuccsessfull, so i'd appreciate any help.


    and here is my log




  • i tried that, now the error is gone, but it still doesnt work

  • As mad as it sounds, I have to set my Grabber config to PAL, but the HDMI2AV to NTSC.


    It's the only way it works properly for me. Maybe try that?


    That is because some of the converters are labeled wrong. I have one that was behaving the same way. When I opened it, the labels on the pcb were switched to the labels on the housing.


    @qwebnm: what is the chipset of your usb grabber? usbtv007 (Fushicai) or stk1160?

  • Same here. Hoping someone has the answer, been up for like 4 days straight getting this all set up. I can also control the lights just fine with the app or though HyperCon SSH. If i stop Hyperion and output the video0 signal to the HDMI i can see the video. I can also take a screen grab with hypercon. If i set Hyperion to an effect like strobe and then take a grabber screen shot the effect stops and hyperion dies. Ive tried PAL and NTSC. This has to be a config issue since the Hyperion and the grabber work fine independently just not together.


    If i try to start hyperion-v412 manually i get this:


    root@raspberrypi:~# hyperion-v4l2 -d /dev/video0 --input 0 --width 360 --height 288 --crop-right 9 --crop-bottom 6
    hyperion-v4l2: version : V1.02.0 (brindosch-f4162eb/2d45d51-1462453507
    build time: May 5 2016 06:07:47
    V4L2GRABBER INFO: width=720 height=480
    V4L2GRABBER INFO: pixel format=YUYV
    VIDIOC_REQBUFS ERROR 16, Device or resource busy






    I get these errors in the log:


    ssh in: Jun 11 00:05:16 raspberrypi hyperiond[3251]: EFFECTENGINE INFO: Initializing Python interpreter
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: INFO: Hyperion started and initialised
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: INFO: Boot sequence 'Strobe Raspbmc' EFFECTENGINE INFO: run effect Strobe Raspbmc on channel 0
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BLACKBORDER INFO: threshold set to 0.001 (1)
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BLACKBORDER INFO: mode:classic
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: started
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: INFO: Json server created and started on port 19444
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: INFO: Proto server created and started on port 19445
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: DISPMANXGRABBER INFO: Display opened with resolution: 1920x1080
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BLACKBORDER INFO: threshold set to 0.001 (1)
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BLACKBORDER INFO: mode:classic
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: INFO: Frame grabber created and started
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: V4L2GRABBER INFO: width=720 height=576
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: V4L2GRABBER INFO: pixel format=YUYV
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BLACKBORDER INFO: threshold set to 0.001 (1)
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BLACKBORDER INFO: mode:classic
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: V4L2GRABBER INFO: signal threshold set to: {25,25,25}
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: V4L2GRABBER INFO: started
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: INFO: V4L2 grabber created and started
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: BORDER SWITCH REQUIRED!!
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    ssh in: Jun 11 00:05:17 raspberrypi hyperiond[3251]: V4L2GRABBER INFO: stopped
    ssh in: Jun 11 00:05:20 raspberrypi hyperiond[3251]: EFFECTENGINE INFO: effect finished




    This is my current config ...



    I'm running Raspian Jessie and I have a UTV007 grabber. I also set this up using raspian weezy from 2013-07-26 since i read that my grabber only works with that kernel. Same thing happned. So i just decided to fire up the current raspian release and give the grabber a shot and it works. Any ideas?





  • I got it working .. had to turn off Internal Frame grabber. Here is my current config. I still need to calibrate and tweak but its working! I removed the LED section. I have 154 so it was quite long.


  • Do you use OpenELEC?
    If yes try the following:


    [INDENT] "grabber-v4l2" :
    {
    "device" : "/dev/video0",
    "input" : 0,
    "standard" : "PAL",
    "width" : 240,
    "height" : 192,
    "frameDecimation" : 2,
    "sizeDecimation" : 1,
    [INDENT](...)[/INDENT][/INDENT]
    OpenElec supports framescaling for the stk1160 grabber, so you can directly tell the driver of the grabber which resolution it should grab.


    Also check if there is enough power for the grabber. Mine doesn't work when connected directly to the Pi. It needs to be connected to a powered usb hub that is then connected to the pi.

  • Quote

    Also check if there is enough power for the grabber. Mine doesn't work when connected directly to the Pi. It needs to be connected to a powered usb hub that is then connected to the pi.

    the screenshots work so that shouldnt be the problem. im gonna try your config now.

  • Just a quick question; as far as I understand it is possible to use both the internal and an external grabber (off course not simultaneously)? Does hyperion switch automatically between the two sources when switching? That should be possible when the priorities are set in the right order I presume?
    I am currently still using an old installation (Bismarcks OpenELEC mit automatisierter Ambilight Quellenumschaltung), it restarts hyperion with a different configuration file on switching the TV input which is signaled via CEC. I would like to upgrade my installation and probably switch to LibreElec, but I want to be sure it can still switch automatically.

  • yes, you could activate both. The grabber with the lowest priority is used.


    Depending on your grabber it is easy or a problem.


    If your v4l2 won't shutdown (cause no picture is available - which is not the case if you use a hdmi to cvbs converter)
    -> You could disable the menu option at the kodi check to shutdown the internal grabber which result in a switch to the external grabber (but if v4l2 is always active (because of a blue picture or so) which means you use the v4l2 always at the kodi menu -> weird)


    In my case i use my tv scart and v4l2 is automatically offline, as long i don't switch to the TV (-> perfect)
    The second problem is: you can't currently differ between color transforms with different grabbers. So one calibration for a digital and the D->A picture. Might be weird too.


    Hyperion should get a CEC component for further configuration.

  • I did also use bismarcks script. My solution was, that I just wrote simple bash scripts that I mapped onto remote buttons. The scripts stop hyperion or start different configs. Was the best solution for me because I could incorporate the buttons with my logitech harmony activities which makes it just as convenient as the script of bismarck. Maybe that could also be a Solution for you

  • Good to hear that, I am using my TVs Scart output which goes directly to the framegrabber so that should be fine (UTV I guess... experimented with both UTV and STK). The calibration will be quite OK I guess, otherwise I'll need to find a compromise. I will give it a try sometime soon!
    Manually switching it with a remote is no option, the switching really needs to be automatic for me to survive the WAF requirements ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!