Odroid C2 with hyperion

  • It feels like I am close to get hyperion running on my Odroid C2.
    I am using the latest Armbian but as I hat the exact same problems on Ubuntu, the way should be the same for both.
    My plan is to make a step by step tutorial for Ubuntu and Armbian for the Odroid C2.

    The Problem is, that hypercon can not install Hyperion on this machine.
    Also all the given tutorials here on the hyperion-project.org wiki dont work at all.

    So far there are only LibreELEC builds with this SoC and only redPanther (not seen anywhere on the internet for ~ a year) had it running on Ubuntu.
    LibreELEC is nice, but its only limited to media center stuff...
    The Odroid has by far more to give and should in my case also beeing used as a apache server, cloudserver, 3d-printserver etc...

    The compileHowTo's for different plattforms on the github (and every other tutorial) are missing commands and information are outdated and mostly for LibreELEc so you get stuck on a different points.
    I have managed to compile and install hyperion on the Odroid C2 but its not working correctly (but it is somehow doing something)...

    After compiling and installing I did
    sudo cp ./bin/hyperion-remote /usr/bin/
    sudo cp ./bin/hyperiond /usr/bin/

    For me it looks like the paths are not correctly or the files has not beeing copied correctly.

    For example there is no "/etc/hyperion/" folder beeing created
    The effects are in "/opt/hyperion/effects".

    After all that my LEDs showed nothing...
    I tried to connect via the hyperion app to set static colors using the colorwheel - not working.

    Then I tried to stop or restart hyperion and now its getting interessting:
    sudo /usr/local/bin/hyperiond restart
    Hyperion Ambilight Deamon (9678)
    Version : master (brindosch-c750c41/dc6a602-1522918225
    Build Time: Jul 6 2018 09:39:14
    ERROR: No valid config found

    No valid config found?

    so I created the folder "/etc/hyperion/" by hand using ftp and copied the hyperion.config.json into it.

    Still NO valid config found...
    hmm.. so lets try to start the hyperion deamon directly on this config:
    hyperiond /etc/hyperion/hyperion.config.json

    INFO: Hyperion started and initialised
    INFO: Boot sequence 'Rainbow swirl fast' EFFECTENGINE INFO: run effect Rainbow swirl fast on channel 0
    EFFECTENGINE ERROR: effect Rainbow swirl fast not found
    INFO: Json server created and started on port 19444
    INFO: Proto server created and started on port 19445
    V4L2GRABBER INFO: width=720 height=576
    V4L2GRABBER INFO: pixel format=UYVY
    BLACKBORDER INFO: threshold set to 0.1 (26)
    BLACKBORDER INFO: mode:default
    V4L2GRABBER INFO: signal threshold set to: {25,25,25}
    V4L2GRABBER INFO: started
    INFO: V4L2 grabber created and started

    The LEDs flickering and are not really showing the correct colors - so there are still some problems else then the wrong paths but at least it is doing something.

    I can now use the hyperion app and connect to the json server.
    Its works 100% like it should while I use the colorwheel.
    As soon as I let the colorwheel go or dont cange the colors continuously the LEDs flicker again.
    Also there are no effects selectable (so the effect folder path is also wrong)

    I hope you guys can help me out with the messed up paths/folders/directories because it feels like there are just a few wrong depencies or paths.

    where should I place the hyperion.config.json correctly or where can I look up the paths that directs to it?
    where should the effects beeing copied to, to be found by hyperion?

    Maybe you also know a possibility why the LEDs fllickering and showing not the right color (with the given paths problems...)

    Thanks a lot!
    Lets make hyperion great again :D

  • I use my Odroid C2 in combination with a RPI2. I couldn't get the LEDs to work without flickering on the Odroid C2. I think the timing of the pins is not good enough to drive the LEDs without sometimes flickering.

  • What does "in combination with a RPI2" mean?
    What is the Odroid and what the Raspberry doing?

    If the image capturing and color calculation work properly I shouldnt have a big issue with flickering as I am using an Arduino to control the LEDs.

    I would really appreciate if you could share how you managed to get this working on an C2 (and which OS you used).

    Thanks a lot!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!