Unable to connect to host.

  • Hi, I have just set up my raspberry pi zero w (running rasbian lite) with Hyperion, however, when I try to send colours to the WS2812b LEDs I have connected to pin 12, I get an error in my ssh window saying "unable to connect to host."


    Here is my log:
    [MEDIA=pastebin]TLqSGmzk[/MEDIA]


    Here is my config:
    [MEDIA=pastebin]d7zvFkCS[/MEDIA]


    When I try to set a colour, or if I use putty to ssh in and manually enter the commands, all i get is:
    ssh out: hyperion-remote -c 3527ff
    ssh in: hyperion-remote:
    ssh in: version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    ssh in: build time: Apr 5 2018 01:57:05
    ssh out: Unable to connect to host



    Any idea what is wrong? seems to be hitting a problem in the logs "Inappropriate IOCTL for device" but I can't figure out what is causing it.




    EDIT: I tried removing the grabber, and starting hyperion with grabber disabled, however this corrupted the OS and needed reinstalling. After that I still have issues, just different ones.


    I can't get a log now, since my rpi gets corrupted every time I start hyperion. The OS doesn't boot, and the screen looks like this until I reinstall raspbian:



    and my current config:
    [MEDIA=pastebin]8ZW7gFVG[/MEDIA]


    OK, this is getting strange. I managed to get the LEDs working, but only if I disable the grabber. If I have the grabber disabled I can use the colour picker to light up specific colours, and if I kill the process, it restarts and I get a rainbow effect. However if I use a config that enables the grabber, I can't send any commands at all.


    Is my grabber bad? it is this one that was recommended on a hyperion tutorial:
    https://www.amazon.co.uk/gp/pr…age_o02_s00?ie=UTF8&psc=1


    This one uses a HW 007 chipset I think, but others recommend a UTV 007 chipset.

  • Heyhey,


    I just signed up here because I started having a similar problem a couple of days ago.
    I built the Ambilight using a raspberry Pi 3 B+ with APA102 LEDs and it worked like a charm the first time right away.


    Since yesterday i now have the problem that after the start-animation (Rainbow) the LEDs turn off even with an active HDMI input source.
    I also had the issue that I got the "unable to connect to host" message whenever iI tried sending a color from either Hyperion on my laptop or the App.


    After disabling the grabber and transferring the new config-file, sending colors worked again.
    Now I can also enable the grabber in the settings again, send this config-file and sending a color still works.
    Nontheless the Ambilight does not react to any image from the HDMI input.


    Additionally i noticed that when I try to "get image from grabber" in Hyperion the program seems to freeze and I have to force close it.
    Occasionally i get an image from the grabber which then is full of artifacts (stripes, wrong colours, image consists of several incorrectly combined pieces etc.).
    The Pi seems to be working nominally, though.


    Now my first thought after the Pi with the grabber dropping once from the back of my TV (Velcro Tape not strong enough) being the only "change" that happened, that one of these devices stopped working properly.


    Therefore I tried:
    - rewriting the raspbian image and reinstalling Hyperion
    - replacing the grabber
    - replacing the Pi


    Result: Nothing but still having the same issue.


    Now the only other components that could in my opinion be a cause for this (IMO) that I haven´t switched out, yet are the HDMI2AV converter and the Chinch-adapter or it has to be a software issue.


    Have you or anybody else here gotten any further or an idea what could cause this?
    It was really a fun project to build and I´d really love getting it to work again.


    I have added a log and my config below.


    Thank you all in advance and have a nice weekend.




  • I haven't gotten any further. Occasionally I manage to get a screenshot to work. I can send colours and effects to my ambilight from my phone, but HDMI input does nothing. The vast majority of times screenshots won't even work, failing with the result "no picture found in ssh traffic, stop hyperion before taking a screenshot". This doesn't seem possible, as if I stop hyperion, SSH disconnects so I can't request a screenshot, and if I reconnect, hyperion has automatically started again. I have tried two different grabbers, one of which has the recommended UTV007 chipset, and still nothing.


    I have heard recommendations that I use a powered USB hub instead of plugging the grabber into the pi directly, however I have seen other people's setups work without this, and I can't find a powered USB hub available anywhere (most hubs just take power from the device anyway...)

  • I might have solved the issue... after increasing the usb power output by adding the line "max_usb_current=1" as well as "hdmi_force_hotplug=1" in the config.txt the grabber could pull an image again and the ambiligt works again.


    Still strange that it used to work wihtout this but at least it is functioning again.
    Hope this does the trick for you aswell!

  • Mike,
    Anyone that can help?



    I have the exact same problem with OpenELEC and LibreELEC os, when I turn off the internal grabber and use the external grabber, my LEDs stop respond and putty says can't connect. When I turn off the external grabber, my LEDs start working again. I set my USB power to max per Bruni's suggestion but that didn't not make a difference. Have you found anything, do you have any suggestions?


    Uploaded two files - Internal config works.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!